Another perlapp not recognized as a PDK tool question

Posted by on 2017-06-16 13:03
Forums: PDK discussion | OS: Windows 10

I had to re-image my personal computer, which wiped out all of my apps. When I searched for Perl 5.8.9 on the net, I found out it's no longer available as a free download from ActiveState. I tried installing the latest version of Perl and got the dreaded "perlapp not recognized as a PDK tool" error. That means my registered PDK software is pretty useless.

Question: What are others doing to get around this dilemma? I've found the Perl 5.8.9 installer on the net, but as a general rule... I prefer to get my software from the developer's site when possible.

Just to note: I did read the finalversionpairingsPDK page, but I'm still not sure what's the best route to follow. My original package is PDK-Pro-, which was updated to PDK-


ActiveState Staff
Tue, 2017-06-20 08:40

PDK 8 won't support any Perls newer than 5.10, and it needed an ActivePerl. Those ActivePerls have not been available as free downloads since 2010. Getting them now means getting a Business Edition license, and given their age and lack of support for Windows 8+, they are not really that useful either.

If you've been using PDK only for the debugger, we suggest a switch to Komodo IDE but there are a lot of good options for Perl debugging.

We're not selling PerlApp or any of the other wrapping tool variants any longer either. There are other vendors still providing wrapping tools that can use a different Perl, as well as the Perl PAR module, but we recommend not wrapping.

glenn.white@sbc... | Tue, 2017-06-20 15:09

Boy, that was tough! Sad to see ActiveState has abandoned us dinosaurs who supported and purchased their products back in the old days. But then again… since I'm retired… I guess I'm not in a position to add much to their bottom line.

Took me quite a while, but I finally found the Perl 5.8.9 installer on the net. I would rather have followed the correct protocol... but us old farts need to make due any way we can. :(