Error /opt/pdk/bin/perlapp not recognized as a PDK tool

Posted by thloeber on 2017-06-14 11:28

I'm trying to setup the PDK 9.5.1 on RHEL 7 64 Bit. When I use Acivestate Perl 5.22 as the designated Perl for the PDK I get the GLIBC 2.14 error when running the compiled perl. So I installed the Perl 5.24 for Linux 64 bit. When I try to use that level of perl, and specify /opt/ActivePerl-5.24/bin/perl on the PerlApp UI I get an error popup that says /opt/pdk/bin/perlapp is not recognized as a PDK tool. Any idea why I get this error please?

grahams
ActiveState Staff
Wed, 2017-06-14 15:17

If you must support older glibc versions, you need a *much* older Perl. The last Linux ActivePerls for glibc 2.5 are 5.18 (now Business Edition only)