MIssing package in new versions (Bot-BasicBot)

Posted by devore on 2016-09-01 11:51
Forums: PPM | OS: Windows 7

As per this (http://code.activestate.com/ppm/Bot-BasicBot/) which is not up to date to 5.24, but it shows Bot-BasicBot (IRC bot framework) is dropped from 5.22 (and not showing up for me in 5.24). I'd use 5.20, but the community version is no longer downloadable. The log from 5.22 build shows, to my amateur eyes, the build was ok, but the test run over time and the job was aborted? Are there any options to download 5.20 again, or otherwise get Bot-BasicBot installed?

i-shenl
ActiveState Staff
Fri, 2016-09-02 09:21

The comments are moderated so there will always be a lag between when you post and when it appears.

PPM for 5.24 is not available yet. We expect it to be sometime in Q3. As for 5.22, neither PPM nor CPAN work for Bot-BasicBot which would suggest that it needs to be updated. My suggestion would be to talk to Hinrik (the maintainer) about bringing it up to 5.22.
http://search.cpan.org/dist/Bot-BasicBot/