Perl installation error

Posted by chaitu1124 on 2016-08-29 13:34

Hi, I tried to install ActivePerl on Linux ( 64 bit ). I got the following error.

perl/bin/perl: /lib64/libc.so.6: version `GLIBC_2.14' not found (required by perl/bin/perl)

Please let me know the solution.

Thanks,
Chaitu

i-shenl
ActiveState Staff
Tue, 2016-08-30 07:45

The reason for this error is the GLIBC version in your OS is too old.

This can happen if you're using a conservative distro like RHEL or CentOS. Conservative distros often stay behind the curve. It turns out that Red Hat says they don't update GLIBC in their kernel:
http://developers.redhat.com/blog/2016/02/17/upgrading-the-gnu-c-library...

What you need to do is find an RHEL or CentOS that uses 2.14 or higher for GLIBC, or use something that uses a more later release (ie, Ubuntu).

grahams
ActiveState Staff
Tue, 2016-08-30 08:04

This topic has been stickied:
https://community.activestate.com/node/12912