El Capitan 10.11.5 Tcl version

Posted by pendukeni on 2016-07-26 15:18

I recently download Python.
After instaling I got this warning

Python 3.5.0 (v3.5.0:374f501f4567, Sep 12 2015, 11:00:19)
[GCC 4.2.1 (Apple Inc. build 5666) (dot 3)] on darwin
Type "copyright", "credits" or "license()" for more information.
>>> WARNING: The version of Tcl/Tk (8.5.9) in use may be unstable.
Visit http://www.python.org/download/mac/tcltk/ for current information.

I then downloaded the recommended ActiveTcl 8.6.4 , however it says its cant install because its from a distributer outside of apple.

Please assist

i-shenl
ActiveState Staff
Wed, 2016-07-27 08:07

The instructions on how to install ActiveTcl are here:
http://docs.activestate.com/activetcl/8.6/at.install.html

It sounds to me that Gatekeeper in OSX might be blocking you from installing. It protects users from inadvertently adding programs/apps that might their system. You can however set it to allow you to install anything including programs that Apple hasn't "approved" yet:

https://support.apple.com/en-ca/HT202491