Error installing ActivePerl 5.24 on CentOS6

Posted by cbbs70a on 2016-07-06 04:44

All;
I was wondering if there is a way to install the new ActivePerl 5.24 on a CentOS6 server. I'm getting an error:

"perl/bin/perl: /lib64/libc.so.6: version `GLIBC_2.14' not found (required by perl/bin/perl)".

Does this mean that unless I am running CentOS7, I can no longer use new versions of ActivePerl as they become available? I have dozens of mission critical customer servers running CentOS6 so its not possible for me to simply switch operating systems.

Thanks;
Frank

grahams
ActiveState Staff
Wed, 2016-07-06 07:39

Depending on what you currently have, Business Edition Licenses would be an option for those servers. You should open a support ticket (support@activestate.com) and we can go over your options in more detail.