which download do I need: activeperl 5.24.0 for windows (x86)|activeperl 5.24.0 for windows (64-bit, x64)

Posted by cellist on 2016-06-28 03:48

at http://www.activestate.com/activeperl/downloads I get two choices:
download activeperl 5.24.0 for windows (x86)
download activeperl 5.24.0 for windows (64-bit, x64)

I want to continue with the same 32-64-bitness as the current AS-version I'm running.

NOTE: I'll be running PDK 9.5. Does that impact which 32-64-bitness???

Here is version info from my currently running perl version:

* perl -V:ivsize says
ivsize='8';

* perl -V:archname says
archname='MSWin32-x86-multi-thread-64int';

* perl -v says

This is perl 5, version 20, subversion 1 (v5.20.1) built for MSWin32-

x86-multi-thread-64int
(with 1 registered patch, see perl -V for more detail)

Copyright 1987-2014, Larry Wall

Binary build 2000 [298557] provided by ActiveState

http://www.ActiveState.com
Built Oct 15 2014 22:10:49

TIA,
Phil

i-shenl
ActiveState Staff
Tue, 2016-06-28 07:42

The x86 installer for 5.24 is the one you want.

However PDK (even the latest 9.5.1) won't recognize 5.24 at this time and we need to update it so that it does. I would advise staying with 5.20 for now until PDK is updated.

To answer your question on 32-64 effect, if you are using a 32 bit version of ActivePerl, you also need the 32-bit version of PDK. It is not possible for a 64 bit version of ActivePerl to work with a 32 bit PDK and vice versa.