PerlApp DateTime::Format::ISO8601

Posted by alodar on 2016-06-10 09:25

In an effort to compile a larger script I was running an error after running the compiled executable. I have narrowed it down to the use of the DateTime::Format::ISO8601. As such I have a script that just has the use of that module in it and nothing else:

use DateTime::Format::ISO8601;

If I put this into PerlApp i get the following error:

The following parameter was passed in the call to DateTime::Format::Builder::Parser::create_single_parser but was not listed in the validation options: regex
at /DateTime/Format/Builder/ line 164.
DateTime::Format::Builder::Parser::create_single_parser(undef, "params", ARRAY(0x4f6f730), "length", ARRAY(0x4f6f6d0), "postprocess", ARRAY(0x4f6f820), "regex", qr(^ T?? (\d\d) (\d\d) (\d\d) $)x, ...) called at /DateTime/Format/Builder/ line 305
DateTime::Format::Builder::Parser::sort_parsers("DateTime::Format::Builder::Parser", HASH(0x3ed91b0), ARRAY(0x3ed7838)) called at /DateTime/Format/Builder/ line 228
DateTime::Format::Builder::Parser::create_multiple_parsers("DateTime::Format::Builder::Parser", HASH(0x3ed91b0), HASH(0x4f6f898), HASH(0x4f6fad8), HASH(0x4f6fd00), HASH(0x4f6ff10), HASH(0x4f70108), HASH(0x4f70368)) called at /DateTime/Format/Builder/ line 363
DateTime::Format::Builder::Parser::create_parser("DateTime::Format::Builder::Parser", ARRAY(0x3ed30a8), HASH(0x4f6f898), HASH(0x4f6fad8), HASH(0x4f6fd00), HASH(0x4f6ff10), HASH(0x4f70108), HASH(0x4f70368)) called at /DateTime/Format/ line 122
DateTime::Format::Builder::create_parser("DateTime::Format::Builder", ARRAY(0x4f703f8)) called at /DateTime/Format/ line 132
DateTime::Format::Builder::create_end_parser("DateTime::Format::Builder", ARRAY(0x4f703f8)) called at /DateTime/Format/ line 78
DateTime::Format::Builder::create_class(undef, "parsers", HASH(0x4f704b8)) called at /DateTime/Format/ line 173
eval ';' called at perlapp line 831
PerlApp::safe_eval() called at PerlApp/ line 102
PerlApp::my_require("DateTime/Format/") called at crypttest.001 - line 2
main::BEGIN() called at /DateTime/Format/ line 0
eval {...} called at /DateTime/Format/ line 0
BEGIN failed--compilation aborted at crypttest.001 - line 2.

I have tried to add DateTime, and DateTime::Format::ISO8601 to the add path, and I have tried adding everything under DateTime::Format::ISO8601, Params::Validate::XS, and Params::Validate::PP to the bind file listing. I keep getting the same error. My assumption is that there is something being calculated at runtime that I need to add as a bind or module but I am having no luck. I would swap out the DateTime::Format::ISO8601 module but its used as part of another CPAN module.

Anyone else run into this with PerlApp and DateTime::Format::ISO8601?

Windows 2008 Server
ActiveState Perl v5.22.1
PerlApp 9.5.1