Newbie Install Issue with Python 2.7

Posted by doclatham on 2016-06-02 00:57


Completely newbie to Python, I thought I was making good progress with Active Python...

I had Python2.7 installed and working. I hadn't used it for a couple of weeks and now whenever I click on the IDLE icon on my desktop, nothing happens. I have un-installed and re-installed from the msi file, no change. I have un-installed and re-installed from command line as administrator - no change. I have tried to run as Administrator. Nothing. If I look in Windows Task Manager, I don't even see anything appear.

The Python Interactive Shell works fine

I tried running pythonw.exe idle.pyw from the command line in the idlelib directory - again nothing

Any help greatly appreciated - I was enjoying working my way through the tutorials and now I have come to a complete halt.

*** Update ****
I subsequently managed to get this error message...

C:\Python27>python lib\idlelib\
Traceback (most recent call last):
File "lib\idlelib\", line 11, in
File "C:\Python27\lib\idlelib\", line 1544, in main
root = Tk(className="Idle")
File "C:\Python27\lib\lib-tk\", line 1814, in __init__ = _tkinter.create(screenName, baseName, className, interactive, want
objects, useTk, sync, use)
_tkinter.TclError: Can't find a usable init.tcl in the following directories:
C:/Python27/lib/tcl8.5 C:/lib/tcl8.5 C:/lib/tcl8.5 C:/library C:/library C:/
tcl8.5.18/library C:/tcl8.5.18/library

This probably means that Tcl wasn't installed properly.

I don't have a tcl8.5 folder on any of those paths, mine is at C:\Python27\tcl\tcl8.5

Does this help at all?

Best Regards


ActiveState Staff
Fri, 2016-06-03 08:28

The IDLE and Tkinter issue is not new, so it should have been affecting you from the beginning. See this for the workaround:

apprenticeharper | Tue, 2016-06-07 09:11

I couldn't find an ActiveState Python/Tkinter bug reporter page anywhere, but now that ActiveState Staff are aware of this issue, can we hope for an updated installer sometime soon?


Alan. (aka Harper)