Install error - teacup can't load tbcload17 library

Posted by johnreid on 2015-10-15 04:10

During failed installation attempts of both ActiveTCL 8.6 and ActiveTCL 8.5 (installer 8.5.9.0) I get the following error (text copied from my attempt at installing 8.5) when it comes to the TEAcup part of the installation:

TEA Package Management - Standard Repositories.

TEAcup @ C:\SVN_source\Tools\ActiveTCL\bin\teacup.exe
Create repository: C:/SVN_source/Tools/ActiveTCL/bin/teacup.exe/entry.tcl: The TclPro ByteCode Loader is not available or does not support the correct version -- couldn't load library "C:/SVN_source/Tools/ActiveTCL/bin/teacup.exe/lib/P-win32-ix86/tbcload1.7/tbcload17.dll": this library or a dependent library could not be found in library path
while executing
"source $startup"
(file "C:/SVN_source/Tools/ActiveTCL/bin/teacup.exe/main.tcl" line 38)
Aborting TEApot setup
Done

This prevents me from running teacup in order to get additional packages I need. I am running with Windows 7 (32-bit).

Does anyone have any ideas as to why?

grahams
ActiveState Staff
Thu, 2015-10-22 13:39

TEAcup needs write and execute access on the $TEMP for the current user. Without write and execute, the internal libraries of SVN_source/Tools/ActiveTCL/bin/teacup.exe will not be found, and TEAcup will crash.