Problems with 'gdata' and Perl - "unable to locate valid perl interpreter"

Posted by miademant on 2015-08-17 01:38

Hi there,

I just installed ActivePerl (ActiveState Software ActivePerl 5.20.2001) but it doesn't seem to communicate with my R Studio program since I get this message everytime I try to run the command "library(gdata)" after I have installed the gdata package. Do you know what I am doing wrong?
Thanks a lot!!

Here's what R Studio says:

" > install.packages('gdata')
Installing package into ‘C:/Users/MDEM0023/Documents/R/win-library/3.2’
(as ‘lib’ is unspecified)
trying URL ''
Content type 'application/zip' length 1178180 bytes (1.1 MB)
downloaded 1.1 MB

package ‘gdata’ successfully unpacked and MD5 sums checked

The downloaded binary packages are in

> library(gdata)
gdata: Unable to locate valid perl interpreter
gdata: read.xls() will be unable to read Excel XLS and XLSX files unless the 'perl=' argument is
gdata: used to specify the location of a valid perl intrpreter.
gdata: (To avoid display of this message in the future, please ensure perl is installed and
gdata: available on the executable search path.)
gdata: Unable to load perl libaries needed by read.xls()
gdata: to support 'XLX' (Excel 97-2004) files.

gdata: Unable to load perl libaries needed by read.xls()
gdata: to support 'XLSX' (Excel 2007+) files.

gdata: Run the function 'installXLSXsupport()'
gdata: to automatically download and install the perl
gdata: libaries needed to support Excel XLS and XLSX formats.

Vedhæfter pakke: ‘gdata’

The following object is masked from ‘package:stats’:


The following object is masked from ‘package:utils’:


Warning message:
pakke ‘gdata’ blev bygget under R version 3.2.2 "

... I am sorry for the last bit that is in Danish, but I hope it still makes sense.

Best regards

ActiveState Staff
Mon, 2015-08-17 08:44

There is a post installation configuration step required, and you are missing modules that RStudio requires.

Strawberry Perl includes a number of modules for Excel XLX/XLSX support.

ActivePerl must install those separately from PPM.

jonasp | Wed, 2018-02-28 02:24

Hi miademant! I am facing the same problem as you, have you been able to resolve it eventually ?
Thank you! Jonas