Error: ppm gui failed: can't find package ppm::themes

Posted by hwkraus on 2015-07-21 06:48
Forums: PPM | OS: Windows 8

Hi,
I wanted to install a module at my current 5.20.1 installation, Win 8.1 64bit.
When starting ppm via the menu entry I get nothing (the circle which vanishes
after a few seconds).

When I typed 'ppm' in a command shell window I got the error:
ppm gui failed: can't find package ppm::themes

I uninstalled Active Perl and installed 5.20.2. The error/behavior remains the same.

I tried 'ppm install ppm::themes' but got the error:
ppm install failed: Can't find any package that provides ppm::themes

Any help appreciated,
Hans

grahams
ActiveState Staff
Tue, 2015-07-21 15:02

Either your Windows settings, the way you have installed Perl, or a third-party product (anti-virus?) is preventing the PPM exe from running.

Does ppm-shell work properly? If you have an AntiVirus running, try disabling it. If you installed to C:\Program Files, installed somewhere other than the system drive, or did not install while logged in as the Local System Administrator ID, try re-installing it on the default PATH using the GUI installer interactively.

hwkraus | Thu, 2015-07-30 03:37

Thanks for the advice. It now works again.

ppm-shell did work, the AntiVirus was not the culprit. It seems that the install dir was it.
I installed it in C:\Programme which is (on german systems) a link to C:\Program Files (I think it is insane from Microsoft to choose a name with a space in it, btw. C:\ProgramFiles should be chosen).

The remedy was installing it in C: directly, thats the default path.

Regards, Hans