Installed ActiveTCL 8.6.4, python/tkinter still gets 8.5.9

Posted by jawknee on 2015-06-28 16:59

I recently upgraded from Mac OS X 10.8/Mountain Lion to 10.9/Mavericks and then to 10.10/Yosemite. At the Mavericks update my python/tkinter app suddenly stop showing images - a known problem and I've installed ActiveTcl 8.6.4, as well as Python 2.7.10. I'm currently on Yosemite and Python 2.7.10.

When I run tclsh, I get this:

$ tclsh
% info patchlevel

But when I run my app, with these two lines at the beginning:

print "Python:", sys.version
print "Tcl revision:", tk.Tcl().eval('info patchlevel')

I get:

Python: 2.7.10 (v2.7.10:15c95b7d81dc, May 23 2015, 09:33:12)
[GCC 4.2.1 (Apple Inc. build 5666) (dot 3)]
Tcl revision: 8.5.9

I've tried reinstalling ActiveTcl several times - no change. I've looked but I can't find this problem or any hint at what to do to fix it.

Any ideas?


jawknee | Mon, 2015-06-29 23:20

This was some sort of a conflict within Frameworks on the Mac. I've never really dealt with them before- but I had some success.

No luck with 8.6.4, so I installed 8.5.18. At this point my python apps were blowing up with a conflict between the "8.5" version in /Library/Frameworks/ and /System/Library/Frameworks, so I moved the frameworks in /System/Library/Frameworks/Tk.framework and /System/Library/Frameworks/Tcl.framework to Old_Tk.framework and Old_Tcl.framework, respectively. This doesn't seem like all that great an idea, but I can change them back and I am getting the new 8.5.18 Tcl.

Would love to get some feedback on this.