Cannot use Tix with ActivePython for Mac OSX (Mavericks)

Posted by tournami on 2015-01-16 19:23


When I tried to do the following:

from tkinter import tix
from tkinter.constants import *
root = tix.Tk()

I get the following error message:

Traceback (most recent call last):

  File "<stdin>", line 1, in <module>
  File "/Library/Frameworks/Python.framework/Versions/3.4/lib/python3.4/tkinter/", line 221, in __init__'package require Tix')
_tkinter.TclError: can't find package Tix

Is there anyway to use Tix on MacOSX? There are no problems using Tix on WIndows 7 version.

ActiveState Staff
Thu, 2015-02-12 16:42

If you're using ActiveTcl to support Tkinter, you can install Tix and other modules for Tcl from the command line.

maurobaraldi | Fri, 2015-03-27 19:42

Can't ActiveState delivery Tix lib compiled to 64 bits together with ActiveState Tcl package, as already does with Tk?