./perl/bin/perl: /lib64/libc.so.6: version `GLIBC_2.14' not found (required by ./perl/bin/perl)

Posted by nissam on 2014-12-05 01:55

Can't install the latest Perl on Oracle Unbreakable Linux

cd ActivePerl-5.20.1.2000-x86_64-linux-glibc-2.15-298557
[xxx ActivePerl-5.20.1.2000-x86_64-linux-glibc-2.15-298557]$ ./perl/bin/perl
./perl/bin/perl: /lib64/libc.so.6: version `GLIBC_2.14' not found (required by ./perl/bin/perl)

At the moment have installed libc 2.12 and yum update tells me that it is the latest version available.

Can't find libc 2.14 in the repos. Could somebody tell where to get it?

grahams
ActiveState Staff
Fri, 2014-12-05 07:57

Conservative Linux distros will stay behind the curve on libc. You're using a Perl version targeted at Cloud-ready Linux, so you might want to move to Ubuntu. As an alternative, there is 5.18 and we offer licensed ActivePerl versions (5.14-5.16) targeted at the conservative distros running on Production Servers.