Cannot install Pycrypto on Python 2.7

Posted by tipiford on 2014-09-12 06:39
Forums: PyPM (discontinued) | OS: Windows 7

I have installed both ActivePython-2.7.8.10-win64-x64.msi and ActivePython-2.7.8.10-win32-x86.msi and attempting to install Pycrypto I get the error "Python version 2.6 is required, which was not found in the registry."

grahams
ActiveState Staff
Fri, 2014-09-19 07:58

There is a prebuilt binary version of Pycrypto for 2.7 32-bit.

DO NOT use the precompiled PyCrypto distribution from voidspace.org.uk

The original post is a known error message triggered by installing the voidspace bits. Those binaries were compiled for Python 2.6 and are *incompatible* with any other Python version.