Issue while installing Getopt::std module

Posted by on 2014-08-15 02:55

I need to install Getopt::std on Windows 7, 64-bit. I have ActivePerl 5.16. When I tried install Get::opt in cpan prompt, I got the following:

cpan> force install Getopt::Std
perl-5.20.0/cpan/Archive-Tar/bin/ptargrep Building R/RJ/RJBS/perl-5.20.0.tar.gz

This version of C:\Perl64\cpan\build\perl-5.20.0-w1MYi4\ is not com
patible with the version of Windows you're running. Check your computer's system
information to see whether you need a x86 (32-bit) or x64 (64-bit) version of t
he program, and then contact the software publisher.
Warning: No success on command[C:\Perl64\cpan\build\perl-5.20.0-w1MYi4\Configure
C:\Perl64\cpan\build\perl-5.20.0-w1MYi4\Configure -- NOT OK
Running make test
Can't test without successful make
Running make install
Make had returned bad status, install seems impossible
Could not read metadata file. Falling back to other methods to determine prerequ
Failed during this command:
RJBS/perl-5.20.0.tar.gz : writemakefile NO 'C:\Perl64\cpan
\build\perl-5.20.0-w1MYi4\Configure' returned status 256

Please help.

ActiveState Staff
Fri, 2014-08-15 07:37

Unless the module is dual-lifed, a core module is coupled to the version of Perl. Your 5.16 Perl already has the version it can use. To use that newer GetOpt-Std, you need to run Perl 5.20.