Unable to install, due to invalid directory choice

Posted by earlgunntute on 2014-07-10 15:43

I can get the ActiveTcl 8.6.1.0 installer (graphic interface) to run, but I'm unable to complete installation due to "/opt/ActiveTcl-8.6": permission denied. How can I overcome this?

Regards.

grahams
ActiveState Staff
Fri, 2014-07-11 06:12

/opt is a protected directory and you will need elevated permissions to write to it. If you install to a protected directory, you will also need to use sudo for maintenance tasks, such as adding and updating modules with the teacup command.

Alternately, consider installing ActiveTcl under your user home directory, where you will not need elevated permissions to install or add modules to it.