Unable to install additional Perl modules MinGW, AppConfig, TimeDate, Text-CSV etc

Posted by cegedim on 2014-06-23 04:18
Forums: PPM | OS: Windows x64

Hi,
For configuring Bugzilla 4.4.4, we have installed Active Perl 5.18.2 in Windows 2008 R2 (64 bit machine). Now while trying to install additional Perl modules (required by Bugzila) MinGW, AppConfig, TimeDate, Text-CSV etc, we are getting below message. To resolve this issue do we need to install any patch, if so could you please let me know where we will get that and the steps to install the same.

C:\>ppm install MinGW
Downloading ActiveState Package Repository packlist...failed 500 Can't connect to ppm4.activestate.com:80 (10060)
ppm install failed: Can't find any package that provides MinGW

C:\>ppm install MinGW
ppm install failed: Can't find any package that provides MinGW

Thanks in Advance!!!!

Regards
Deb

grahams
ActiveState Staff
Mon, 2014-06-23 13:46

.failed 500 Can't connect to ppm4.activestate.com:80 (10060)

Check to see if you have a proxy server in the middle, and if so, follow the FAQ for setting up with a proxy:
http://docs.activestate.com/activeperl/5.18/faq/ActivePerl-faq2.html#ppm...

cegedim | Tue, 2014-06-24 03:43

Hi,
I have added proxy setting under environment variable as per the FAQ for setting up proxy, and then tried to install MinGW, now i am getting ...failed 400 Bad Request...but from the same machine I am able to access following link http://ppm4.activestate.com/MSWin32-x64/5.18/1802/package.xml without any problem.

C:\>ppm install MinGW
Downloading ActiveState Package Repository packlist...failed 400 Bad Request
ppm install failed: Can't find any package that provides MinGW

Thanks
Deb

grahams
ActiveState Staff
Tue, 2014-06-24 07:48

MinGW does not exist for 5.18 - 64-bit. This can be confirmed by parsing the package.xml file for a matching Softpackage descriptor. It is not there.

If your instructions call for MinGW, you are probably using the wrong Perl. MinGW is a 32-bit only package. The equivalent would be MinGW64, but that compiler is still not fully available via PPM. (Open bugs).

You could try the 32-bit version of 5.18 instead, but you will likely have more success using 5.16 32-bit.