Tclchecker complaining about Tk commands

Posted by olwen.morgan@emerson.com on 2014-04-01 02:42
Forums: TDK discussion | OS: Windows 7

First post here, so please bear with me if I seem a little slow ...

I've just got TDK and am using it under the Geany IDE. No problems integrating TDK elements into Geany but whenever I run tclchecker over my code, it complains about unknown commands for every TK command in the source.

I've checked the FAQ and can't find any help on this one.

Is this the expected behaviour of tclchecker, or is there an option that I'm not setting correctly?

Puzzled,

Olwen Morgan

grahams
ActiveState Staff
Tue, 2014-04-01 07:52

is not something I can support, but the behaviour sounds like you have configured your IDE to use the tclsh executable, and should be using the wish executable instead.

olwen.morgan@em... | Tue, 2014-04-01 08:25

My IDE uses wish85. Geany is simply set up to run tcl as a command and redirect stdout to file that it filters to display in one of its windows.

tclchecker produces the same results whether I run it via the Geany IDE or on the command line. If I am using tk commands, does there have to be something in my code that tells tclchecker that I am using Tk?

olwen.morgan@em... | Tue, 2014-04-01 08:26

... whoops! ... I should have said that Geany runs *tclchecker* as a command ...

... sorry... :-)