ActivePerl for Windows 8.1 that uses MSVCR110

Posted by twardega on 2014-03-11 11:59

Hi,

I would like to develop a desktop app for windows 8.1 using ActivePerl. The most recent version of ActivePerl 5.18.2 depends on MSVCRT.DLL - as far as I understand MSVCRT.DLL cannot be used in a Windows 8.1 store app, MSVCR110.DLL and related DLLs should be used instead. Since Microsoft is forcing the move to Window 8.1 will ActivePerl for Windows 8.1 be compiled against MSVCR110.DLL and related runtime libraries?

Tomek Wardega

grahams
ActiveState Staff
Wed, 2014-03-12 08:02

ActivePerl for Windows needs to be backward compatible with older versions of Windows, so until all the versions of Windows that shipped with older versions of the MSoft C runtime are End-of-Lifed, it's unlikely that you will see an ActivePerl compiled against msvcrt110.dll.

Compiler changes are not trivial. Changes in the compiler suites used for ActivePerl with 5.18 have been the source of months of cumulative delays for Perl and PDK releases.

twardega | Wed, 2014-03-12 10:19

Thank you for your reply, it sounds that I will have to stay away from Windows App Store. I have a follow-up question: is there an ETA for PDK 9.3 with Perl 5.18 support? Last time I checked (a few months ago) ETA was around February 2014.

Best regards,

Tomek Wardega

grahams
ActiveState Staff
Wed, 2014-04-30 13:51

Out now.