ppm install failed: 503 Service Unavailable

Posted by jviolett on 2014-01-16 08:29
Forums: PPM | OS: Other Linux

I recently had to reinstall our ActivePerl 5.16.3 installation (which went fine) and then reinstall the CPAN modules that we use. I do this by doing a series of 11 ppm calls.

Ten of the ppm invocations executed completely correctly - so there shouldn't be a connectivity issue - but one of them failed. I was unable to install Config::Simple, getting the message below:

ppm install Config::Simple
Downloading ActiveState Package Repository packlist...done
Updating ActiveState Package Repository database...done
Syncing site PPM database with .packlists...done
Downloading Config-Simple-4.58...failed 503 Service Unavailable
ppm install failed: 503 Service Unavailable

Just in case it was a fluke, I tried again, but I got the same error. Can anyone suggest a course of action?

Thanks.

jviolett | Thu, 2014-01-16 13:24

Well, there's some good news. A few hours after experiencing this problem (twice), I tried a "ppm install Config::Simple" again, and it worked.

There is very little chance that I did anything different in the successful invocation; I'm thinking the problem was over here, and got resolved.

Somehow.

For now.

grahams
ActiveState Staff
Fri, 2014-01-17 11:04

One of the servers in the cluster was mis-behaving yesterday. IT has been working on swapping it out. There are still some issues today, but they should be transitory.

jviolett | Wed, 2014-01-22 08:27

Thanks. Good to know this had a probable cause that you've addressed.