Unable to install teapot, while installing ActiveTcl8.6 in ubuntu 10.04 "

Posted by balup on 2013-11-13 02:07

Hi,

I am trying to install TCL package in my Ubuntu 10.04 machine. I have downloaded ActiveTCL_8.6 and installing this using "./install.sh" command. TCL installation is succesful, But while installing "teapot" I am getting following errors.

TEA Package Management - Standard Repositories.

TEAcup @ /opt/ActiveTcl-8.6/bin/teacup
Create repository: /opt/ActiveTcl-8.6/bin/teacup: /opt/ActiveTcl-8.6/bin/teacup: cannot execute binary file
Aborting TEApot setup
Done

Without this teapot package I am unable install some libraries.

Please help me to resolve this issue (to install teapot in ubuntu 10.04). Thanks in advance.

Thanks,
Balu P.

grahams
ActiveState Staff
Wed, 2013-11-27 15:43

Make sure that you used GNUtar from the command line to extract the files. If you have used the Linux archive manager, some of the files will have been corrupted during extraction.

Systems which supply dash as the default shell should run the install script with
bash ./install.sh

If you have installed using sudo, you will need to also run teacup with sudo.