Unable to install MIME-tools on system ‘Winserver 2003 R2 standard x64 SP2’ where perl version is ’ v5.8.8'

Posted by sharmapriya on 2013-10-18 01:38
Forums: PPM | OS: Windows Server 2003

Hi

My system is ‘Windos server 2003 R2 standard x64 edition SP2’ and perl version is ’ v5.8.8 built for MSWin32-x86-multi-thread’.

perl -v

This is perl, v5.8.8 built for MSWin32-x86-multi-thread(with 25 registered patches, see perl -V for more detail)

Copyright 1987-2006, Larry Wall

Binary build 817 [257965] provided by ActiveState http://www.ActiveState.com Built Mar 20 2006 17:54:25

Perl may be copied only under the terms of either the Artistic License or the GNU General Public License, which may be found in the Perl 5 source kit.

Complete documentation for Perl, including FAQ lists, should be found on this system using "man perl" or "perldoc perl". If you have access to the Internet, point your browser at http://www.perl.org/, the Perl Home Page.

I am not able to install MIME-tools on my machine.

1. I have tried to install MIME-tools via ppm, but getting error:

ppm> search MIME-tools
Searching in Active Repositories
Error: No valid repositories: Error: 404 Not Found

2. Then I tried to install it manually, 'perl Makefile.PL' command run successfully but when I run 'make/nmake' cmd, getting error 'make' is not recognized as an internal or external command,operable program or batch file.'

D:\sharmap\MIME-tools-5.411>perl Makefile.PL
Checking if your kit is complete...
Looks good
Warning: prerequisite IO::Stringy 1.211 not found.
Warning: prerequisite Mail::Field 1.05 not found.
Warning: prerequisite Mail::Header 1.01 not found.
Warning: prerequisite Mail::Internet 1.0203 not found.
Writing Makefile for MIME-tools

D:\sharmap\MIME-tools-5.411>make
'make' is not recognized as an internal or external command,operable program or batch file.

D:\sharmap\MIME-tools-5.411>nmake
'nmake' is not recognized as an internal or external command,operable program or batch file.

Please help me to install MIME-tools module.

grahams
ActiveState Staff
Fri, 2013-10-18 09:36

That build has been out of support since June 16, 2008.

Support for 5.8 Perls needs a Business Edition license. The Business Edition recommended roll-up for 5.8 Perl is 5.8.9.829.

sharmapriya | Fri, 2013-10-18 10:26

Thank you for the help.