Issue with changing token expiration in web console

Posted by lorned on 2013-09-09 15:45

I'm getting errors with my cloud controller after I modify my token expiration time in the web console. /s/logs/cloud_controller.log has messages like cloud_controller ERROR -- Exception Caught (TypeError): can't convert String into an exact number. How can I fix this?


We've identified an issue with the web console setting the token_expiration value as a string rather than a numeric, which leads to this problem. An easy work-around for this, as well as a remedy, is to set token_expiration from command line from one of the nodes in the system. Open a terminal session to one of your stackato nodes and enter the following:

$ kato config set --force cloud_controller keys/token_expiration

where is the number of seconds you'd like to set for a token expiration value. The --force flag will force kato to set the value as 'numeric' in case it's been overridden as a string.

A patch for this issue will be forthcoming.