Not able to install Net::SSLeay perl module on Solaris x86 OS

Posted by amarnath-rachapudi on 2013-08-27 02:43
Forums: PPM | OS: Solaris 10 ( X86 )

On a Solaris x86 machine, we have Active perl 5.12 version installed.
We wanted to support SSL communication from Perl application.

When i tried to communicate to a HTTPS url i get the following error.
500 Can't locate object method "new" via package "LWP::Protocol::https::Socket"

On debugging, realized that we don't have the needed Net-SSLeay module installed. Hope that is causing this error.

When we tried to install Net-SSLeay using ppm, we get the following error.

We have Perl Business Edition license. I hope ppm should allow us to install the needed modules.

# ./ppm install Net-SSLeay
Downloading ActiveState Package Repository packlist...not found
ppm install failed: Can't find any package that provides Net-SSLeay
# ./ppm install Net::SSLeay
ppm install failed: Can't find any package that provides Net::SSLeay

grahams
ActiveState Staff
Thu, 2013-09-05 13:07

http://code.activestate.com/ppm/Net-SSLeay/

There is a 5.12/32-bit Sparc version of Net-SSLeay available, but there are no x86 versions.

Best option is to use the "cpan" script, and build the latest release (and any missing dependencies) of Net-SSLeay from source.