Stackato 2.10.X Combined Rails3 Framework patch

Posted by jamesf on 2013-08-21 12:31
OS: All / Any | Product: Stackato | tags: 2.10.4 2.10.6 mysql nokogiri patch rails rails3 ruby stackato
Question: 

Q1: My app using the rails3 framework won't deploy, I see some errors when Gemfiles are being installed. I am using Nokogiri 1.6.0

Q2: I am seeing an error "Please install the mysql adapter: `gem install activerecord-mysql-adapter`" when I deploy my rails app"

Answer: 

We have fixed these bugs in the rails3 framework caused by changes in external ruby gems and created a combined patch. This patch is available here for 2.10.4 users:

http://get.stackato.com/patch/2.10/stackato-2.10.4-rails-mysql-nokogiri-...

If you are using 2.10.6, you may install this patch via "kato patch". See the following FAQ for more info about kato patch: http://community.activestate.com/node/10156

Please contact ActiveState support if you have any questions about this patch.