TDK discussion

Tcl Dev Kit usage questions; Tcl Dev Kit practices and project questions

problem occur running starpack on Mac when tcl files are compiled

I'm trying to generate a standalone Tcl application using tclapp. The generated runtime works as long as I don't compile the Tcl code.

The error I get when I run the compiled runtime is:

test.tcl: The TclPro ByteCode Loader is not available or does not support the correct version -- dlopen(/var/tmp/tclwNROwK, 6): no suitable image found. Did find:
/var/tmp/tclwNROwK: file too short
while executing
"source $startup"
(file "main.tcl" line 38)

-is redirect

Have received this type of message and causes the creation of an executable to 'abort'.

package 'whatever' -is redirect is not known (Specified, Not recoverable)

Would appreciate an understanding of what this means and how to include the associated code in an executable.

Cant select basekit MacOS TDK5 Licensed

Hi, cant someone explain why I cant select interpreter in TclApp. When I go to /Library/Tcl/basekits I can see them but cant select base-tk8.6-thread-macosx10.5-i386-x86_64? It stays grey?

Problem debugging subprocesses/spawnpoints in TDK

I'm trying to run through the 'Debugging Subprocesses' example that is shipped with TDK and it is not behaving the way that the tutorial explains it should.

Reading compiled applications

Is it possible for a compiled applications (.exe) to read the contents of another compiled exe.
I would like to obfuscate and deploy files to be read by an installed application.
How does one do that.

Infinite Loop when Debugging through Logger library

TclDevKit5.4.1.299366-win32-ix86-threaded
Tcl 8.6.4
Tcllib 1.17
Windows 10 Pro - 64 bit

I am debugging code that uses the tcl logger library. Pertinent code is as follows:

package require logger

# Global Logger Creation
set log [logger::init global]

# Initialize a log file channel for each severity level.
foreach lvl [logger::levels] {
interp alias {} DispAndLogIt_$lvl {} mccnet::DispAndLogIt $lvl
${log}::logproc $lvl DispAndLogIt_$lvl
}

proc OnGo {} {
global log
${log}::info "Operator has selected Go button."
}

TCL Dev Kit Win 10 Permissions

Active State probably should update the installation instructions for the TCL Dev Kit. In Windows it installs by default under C:\TclDevKit, but under Windows 7/8/10 any directory under C: does not inherit modify permissions for the group "Authenticated Users". That means after a default install, none of the tools will be able to modify working directories under an Authenticated User's home directory.

You'll get a message like "Unable to modify working directory. Access denied." the first time you try to create a project.

Different color rendering in interpreter vs. wrapped app

I'm wondering why the "green" color I'm using to -fill a canvas object is bright green when I run my app via the interpreter, and dull green when I run the app generated by TclApp.

Any ideas?

Joe Schroeder

Is it efficient to save the exec state in TCL and how do we do it?

Hi all,

I want to save the whole process context, including the exec state. I know it is feasible but I don't know if with a script language it is efficient and how to do it.
My goal is to chose the best language to to this, and I'm in this community to find out on TCL about this subject.

Thanks to all,
Mambo.

Tcl package with Dev Kit Crashing

I have an application that is wrapped using Tcl Dev kit. I've built my own basekit using the below command line and it has been working fine for years. However, I recently saw this crash on a Windows 7 system that it was recently installed on. It happens often on this system.

Error message says "ActiveState Basekit has stopped working". I have the full error messages in a windows crash dialog I captured (jpeg). Is there anyway I can include that capture here?

Thx
Al Silverstein