PPM

Discuss the Perl Package Manager (PPM) and other module installation methods

Error Installing package 'math-random' could not locate a PPD file for package math-random

After installing Activeperl-5.16.3, I ran the followings in the DOS command prompt

ppm install math-random
ppm install statistics-distributions
ppm install archive-zip
ppm install file-copy-recursive
ppm install moosex-params-validate

I get the underlisted error for each of the comman e.g

Error Installing package 'math-random' could not locate a PPD file for package math-random.

I need help.
Regards,
Muyiwa

repository for text-unidecode

Any idea where I can find a PPM repository that has text-unidecode?

Problem in installing cpan> DBD::mysql

Hi,

I am new to Perl. Tried to connect to database MySQL with Perl program.

Ran this cpan> install DBD::MySQL

Error connect to server at 'localhost' failed -- error 'Access denied for user'ODBC'@'localhost' (using password: NO)'

Running make test
Make had some problems, won't test
Running make install
Make had some problems, won't install
Couldn't read metadata file. falling back to other methods to determine prerequisites

Please some one can guide me
Thanks

install DBD::mysql error connect to server at 'localhost' failed. Second error Make had some problems, won't install

Hi,

I am new to Perl. Tried to connect to database MySQL with Perl program.

Ran this cpan> install DBD::MySQL

Error connect to server at 'localhost' failed -- error 'Access denied for user'ODBC'@'localhost' (using password: NO)'

Running make test
Make had some problems, won't test
Running make install
Make had some problems, won't install
Couldn't read metadata file. falling back to other methods to determine prerequisites

Please some one can guide me
Thanks

Can't find number-format package

I have been using ActiveState Perl for several years. I recently received a new computer, and installed ActiveState Perl 5.18.2. I then went to add the packages I use, and was able to add all of them except "number-format", which didn't show up in the package manager. Is that package no longer supported, or am I doing something wrong?

Thank you.

ActivePearl package issue

Hello,

I'd like to install bugzilla in Windows Server 2012 x64, with IIS 8.5, MySQL and ActivePerl 5.18 - and I have a problem with ActivePerl 5.18 package installing.

I downloaded the installer from activestate.com, install the program and opened the PPM (version 4.19). After this I'd like to install the packages wrote by https://wiki.mozilla.org/Bugzilla:Win32Install in PPM gui and in CMD too with "ppm install AppConfig", but the return msg is "ERROR: 500 Can't connect to theryx5.uwinnipeg.ca:80 (Bad hostname)".

Dom.pm

I have installed ActivePerl 5.16.3. I have also done a install XML::DOM in cpan shell as follows:
cpan> install XML::DOM
Still when I use XML::DOM in a module, I get the following error:
C:\Users\Dell\Downloads\ROUGE-1.5.5 (1)\RELEASE-1.5.5>ROUGE-1.5.5.pl
Can't locate XML/DOM.pm in @INC (@INC contains: C:/Perl64/site/lib C:/Perl64/lib
.) at C:\Users\Dell\Downloads\ROUGE-1.5.5 (1)\RELEASE-1.5.5\ROUGE-1.5.5.pl line
173.
BEGIN failed--compilation aborted at C:\Users\Dell\Downloads\ROUGE-1.5.5 (1)\REL
EASE-1.5.5\ROUGE-1.5.5.pl line 173.

PPM re-installing previously uninstalled module

Hi,

I am trying to reinstall a previously uninstalled package, in the Perl Package Manager GUI. Earlier I uninstalled Win32-SerialPort by accident. I am trying to reinstall it, but it doesn't come up in any search results, when viewing all packages. So I thought that uninstalling it might have left something behind, by viewing Installed packages. If it doesn't show up in the search results, how can I go about re-installing the package again? Attempting to install it on the command line fails as well, stating that it can't find it.

Platform - Windows XP
Perl version - 5.18.2

PPMX download requires a Business Version authentication of some sort..?

windows 7
perl v5.16.3

I need Spreadsheet::Read / WriteExcel. Was able to PPM install these onto my laptop. However, my current contract finds me behind the Great Wall. Thought I might try PPMX approach but I'm asked for a Business Version login when trying to download the PPMX file for Spreadsheet:: modules. I don't believe I have one of those..

Just wondering what the logic is.. available thru PPM but not the PPMX approach..

Any work-arounds ?

Thanks much in advance..
Mark

Unable to install additional Perl modules MinGW, AppConfig, TimeDate, Text-CSV etc

Hi,
For configuring Bugzilla 4.4.4, we have installed Active Perl 5.18.2 in Windows 2008 R2 (64 bit machine). Now while trying to install additional Perl modules (required by Bugzila) MinGW, AppConfig, TimeDate, Text-CSV etc, we are getting below message. To resolve this issue do we need to install any patch, if so could you please let me know where we will get that and the steps to install the same.

C:\>ppm install MinGW
Downloading ActiveState Package Repository packlist...failed 500 Can't connect to ppm4.activestate.com:80 (10060)