PPM

Discuss the Perl Package Manager (PPM) and other module installation methods

File-Scan-ClamAV failing to compile

Hi,

It looks like the File-Scan-ClamAV module is not available because of a compile error. I've run into this issue in the past and I've corrected by exporting CLAMD_PATH=/path/to/clamd before running the compile.

Who can correct this issue on the build server so the module can show up for PPM?

http://ppm4.activestate.com/x86_64-linux/5.22/2200/E/ES/ESAYM/File-Scan-...

Spreadsheet-ParseXLSX not available in ActivePerl 5.22.1.2201-MSWin32-x64-299574

I have just installed ActivePerl 5.22.1.2201-MSWin32-x64-299574 and I don't found Spreadsheet-Parse XLSX, which was available at some previoous versions.

I tried to install using cpanp and failed installing Crypt::Mode:CBC, wich isn't in ppm.

Is there a version of Spreadsheet-Parse XLSX available for ActivePerl 5.22.1 anywhere?

Thanks,

Imager package (perl 5.22.1 / 64) seems "uncomplete"

Good evening,

Having installed Imager:: package I tried to obtain information about some TIFF files (their DPI tag).

ActiveState Imager:: returns an error stating that it does not handle TIFF, JPEG and others, but only BMP, raw,...

On CPAN description for Imager it is specifically stated that Imager does handle these formats.

Is there any complementary ActiveState module to Imager that I should install to access these formats?

SNMP::INfo

Just installed the latest ActiveState Perl 5.22.1 for Windows (x86), and my application needs SNMP::Info, and this package build has failed per:

https://code.activestate.com/ppm/SNMP-Info/

I need to know how to install this module.

Thanks.

ppm install failed: 500 Can't connect to cpan.org:80

hi all,

I am getting this error while installing a module

ppm install failed: 500 Can't connect to cpan.org:80

would anybody help me to resolve this, I am using windows8.

Thanks

Request for increasing timeout window

We are interested in using Wx. According to http://code.activestate.com/ppm/Wx/, the build attempts failed on the latest versions. But when you look at the end of the build logs, you would see that they actually did not fail, but hit to the timeout wall.

> Timeout (max run time is 1680s)
> C:\Perl64-5.20\bin\perl.exe exits with 37.

> Timeout (max run time is 1200s)
> /data/fly2000/ap2000-298540/bin/perl-static killed by signal 15.

Would you please increase the timeout window and test the latest Wx for 64-bit Windows, Linux, and Mac OS X?

Thanks.
--mehmet

How to add missing packages

I'm trying to install bugzilla, that requires various perl packages such as TimeDate. I cannot find these in the activeperl installation I have just installed. PPM does not know of the packages.
How do I find and add these with activestate perl ?
Thanks

Number of modules failing to install

I had to downgrade from Perl 5.20 to 5.18.4 a few days ago. Now, a number of modules I need for Bugzilla will not install:
ppm install Net-SMTP-SSL, JSON-RPC, etc.
Error is "... failed 500 write failed: Bad file descriptor"
I am trying to install in a DOS window with Admin privs.
3/4 of the modules that I selected installed fine. The other 1/4 have this issue.

Please advise.

Dancer2 via PPM

Would love to install and use Dancer2 via PPM, however according to the build logs, the build times out after 7mins. ActiveState can you kindly review and re mediate? This is a large module, it's going to take longer to run all the tests, that's ok. It's this kind of stuff that honestly gives me more reason to move to Strawberry Perl. If you are going to have a package manager then support the packages.

Trying to install XML::LibXML

No joy in installing XML::LibXML

I'm running Perl -v5.20.1 (32 bit) on Windows 8.1.

The PPM does not have XML::LibXML available for install on this version. I tried installing directly from CPAN but ran into issues there that I don't really understand. It looks as if I were to drop back to Perl v5.16 there is a compatible version.

Can someone advise as to whether this is my only option?

Thanks
Brad