PPM

Discuss the Perl Package Manager (PPM) and other module installation methods

No PPM gui with vista

Hi does anyone know if there is a way to get the ppm gui working with Vista?
I got .820 but no luck any ideas?

PPM generated doc contains wrong link

I noticed that when install a package via PPM(I am using ppm4), it automatically generates HTML document for the package. When I try to read the doc, it is formated correctly, but all the links on the page that suppose to point to a method or another module are linked to some absolute path of a temp-install directory:

For example, I installed the "Net::DNS" package. If I take a look at the "Net::DNS" html doc generated by PPM, the page looks ok. But if we roll down the page to ALSO SEE section, the links are pointing to something like:

file:///C:/Perl/html//DOCUME~1/plee/LOCALS~1/Temp/ppm-PU2snI/Net-DNS-0.5...

PPM UPgrade problem

I am new to Perl and have a question. I recently used PPM (v3.4) to install the Class-DBI and DBD-ODBC modules. When I run the upgrade, I notice 2 items that will not upgrade. Do I need to worry about them? They are;

"Class-DBI 3.0.6: new version 3.6 available in ActiveState Package Repository" It will launch the installer, but when it is finish, the version never changes.

"Term-ReadLine-Perl 1.2.3.2: new version 1.0302 available in ActiveState Package" I will get a permission error because PPM is using the module.

I have tried ppm upgrade [module name] -install -precious -force in many variations with no luck.

"error U1073: don't know how to make '/usr/lib/perl5/5.8/cygwin/Config.pm'", on win2k, how can I solve it?

I'm trying to compile some perl pgms on my windows2k SP3 so I installed the following in order to do it:

ActivePerl 5.8.8.819
Cygwin 2.510.2.2
Parse::Binary module 0.10
nmake 15

When I run:

perl Makefile.pl, all is OK

when I run:

nmake, I got the error described previously (U1073).

If I edit the Makefile, I found the following variables:

LDDLFLAGS = -s -L/usr/local/lib
LDFLAGS = -s -L/usr/local/lib
LIBC = /usr/lib/libc.a
LIB_EXT = .a
OBJ_EXT = .o
OSNAME = cygwin
OSVERS = 1.5.18\(0.13242\)
RANLIB = :

pmm install error

While trying to install Archive-Zip.ppd, I received the following error:
ppm install failed: Installing Test-Simple-0.47 sould downgrade Test::Builder form version 0.32 to 0.17 and Test::More from version 0.62 to 0.74 and Test::Simple from version 0.62 to 0.47; use --force to install regardless

Q1: Do I care about this error? an why?
Q2: If I care where do I get a a version to Archive-Zip that will not produce this error?

rec

Why not to keep PPM3 for users with slow connection?

Dear developers,

The PPM3 is really the thing I am missing now. I have extremely slow dialup connection and therefore cannot use PPM4 on my system. For 819 version of Perl now I have to go to ppm repository site and manually download zipped packages and install them from command line. I tried to exhaustingly wait until it updates the registry on my machine, but after waiting for 30-40min, I stopped the process as it was processing packages with names, started from D (I used ppm-shell, as ppm GUI hangs while trying to download the list of packages, which results in my PC, coming to a standstill). PPM3 worked perfectly on my system (search and install usually took several minutes). I have P3 1,1Mhz, RAM-512Mb, WindowsXP SP2. Won’t it be possible to make an installation time option to install PPM3 instead/with PPM4?

Thread::Pool ppd

hi there,

I want to use Thread::Pool, but the version in ppm is 0.1, which does not work with perl 5.8 threads, because it uses the older "Thread" implementation.

I would like to use version 0.32 which is maintained by another person (Elizabeth Mattijsen) on CPAN.org, but have no way of building it, and it requires many other modules.

Can someone please compile the package, and send me the ppd and add it to ppm.

I am running activeperl 5.8.x on Windows XP, SP2.

Thanks in advance for all your help.

-Jeremy A.

ppm fails for users with non-ASCII usernames

ppm in ActivePerl 819 on Windows fails to start up for users with non-ASCII user names. The error message displayed is something like:

  ppm gui failed: DBI connect('dbname=C:\Documents and Settings\<username>
    \Application Data/ActiveState/ActivePerl/ppm-MSWin32-x86-multi-thread-5_8.db',
    '',...) failed: unable to open database file(1)

This is caused by limitations in perl's handling of Unicode and we plan to address this issue in the upcoming release. The recommended workaround is to tell PPM to access its state database from a path consisting of plain ASCII characters only. It is achieved by setting the ACTIVEPERL_PPM_HOME environment variable to the name of a directory that ppm should use. For instance:

Cant use PPM

I read from the documentation that PPM is installed by default with ActivePerl.
I understand any ActivePerl, even the linux distribution, am i wrong?

I cant run PPM.

I have installed ActivePerl DEB via dpkg... try Freespire and Ubuntu, in both i dont know how to run PPM if posible.

PPM 4 enhancement requests

Here are some enhancements I would like to see:

1. Option to continue to use PPM from the command line as in version 3 rather than only for specific sub-commands

2. Option to issue sub-commands manually (rather than point and click) in the GUI

3. Be able to choose which repository to download a package from

4. Be able to highlight more than one package at a time in the GUI

The GUI is quite nice, but I think a little more flexibility for the end user such as those suggested above would be good too.