PPM

Discuss the Perl Package Manager (PPM) and other module installation methods

Installing Crypt::SSLeay on ActiveState perl Linux

hi! I am have finished my project and have created a windows binary using perlapp. I now need to do the same on Linux. I have installed ActiveState Perl and am trouble finding Crypt::SSLeay package that will install on linux. Can anyone help me out?

Using PPM on Vista Enterprise Edition

I have recently completed an upgrade from Windows XP Professional to Windows Vista Enterprise Edition. Upon doing so, I installed Active Perl 5.8.8 Build 820; however, I have had no success in getting the PPM (either the CLI or the new-to-me GUI) to install .ppd packages. Upon launching PPM, I get a default pre-installed list of 42 packages, but I can not perform any searches of Internet repositories. I am frequently met with "read failed - 500 error" messages. I am not using any proxies or firewalls (aside from the built-in Vista Firewall, and even if I disable it, I see the same issue).

Posting New PPMs

I've recently become the owner of CPAN's OpenGL module, and I'm in the process of posting a new major release (0.55) - the first update in about 7 years.

I've created 5.6x and 5.8x PPMs (http://graphcomp.com/opengl#dist), and would like to know how to submit them to ActiveState's repositories.

Please respond to bfree@graphcomp.com

Thanks - Bob Free

Unable to install GD 1.91

I need to use SnortAlog on a Windows XP machine. I have installed ActivePerl and I need to add the GD support for Perl. The author of SnortAlog says to use GD 1.91, but I can't get it installed into ActivePerl. There is no PPM file to use with PPM to install it.

How can I get GD 1.19 installed?

Encode on 5.6.1

I'm new to MS Windows and using perl on it...I'm using version 5.6.1 as required by the SDK I'm using.

I find myself needing the Encode perl module :

>perl test.pl
Can't locate Encode.pm in @INC (@INC contains: C:/Perl/lib C:/Perl/site/lib .) a
t test.pl line 17.
BEGIN failed--compilation aborted at test.pl line 17.

so I figure I need to install it, but am having trouble.

My first attempts resulted in

ppm> install Encode
====================
Install 'Encode' version 1.99 in ActivePerl 5.6.1.638.
====================
====================

sftp

Anyone get sftp to work.

It does a connection, and login.

Then just hangs.

ppm repository for 5.6

I'm trying to use PPM for ActiveState Perl 5.6, and I've tried setting the
repository as specified in the faq
http://aspn.activestate.com/ASPN/docs/ActivePerl-5.6/faq/ActivePerl-faq2...
but "search" returns nothing when I try to use the ActiveState PPM repositories (I've tried the non-ActiveState ones and some of them do work but only have a very small set of modules).
Are the ActiveState repositories listed in the faq correct?

Chris

PPM user area doesn't exist?

Hi,

I am having a little difficulty with PPM. I have installed ActiveState's distribution off of the web, and I installed to a directory called C:/Program Files/Perl. I fixed my PATH in Windows to recognize space-including file paths, but now PPM is having a fit with installing new packages.

Specifically, when I open the program, it seems to synchronize fine, but then the program hangs. I cannot see local packages. I can access menu items fine. When I go to Preferences to add sites to check, I get the following messages:

Script using DBI doesn't work after mysql upgrade

Hi everybody,
I have two simple scripts that worked beautifully up to the moment that I upgraded MySql from 3.23 to 4.1.22.

Neither data nor scripts have been changed

I assume that DBI/DBD-Mysql don't like the new version...?

I'm using Perl 5.8.7.,Build 815.

A script snippet:

use DBI;
$dbh = DBI->connect('DBI:mysql:mydatabank', 'myuser', 'mypassword');

The error message reads: "Can't locate object method connect via package DBI".

DBI and DBD-mysql are correctly installed.

Not even this works any more.

Any help would be greatly appreciated.
Many thanks!

PPM doesn't update, but no error

Hello:

I'm using PPM 4.0 to update my packages.

However, my packages don't get updated. PPM claims that it's downloaded and installed them, but when I refresh it shows the exact same packages need to be updated.

Checking the site dir shows that the packages really didn't get updated.

This happens from the GUI or the CLI.

Thanks!
Greg