PPM

Discuss the Perl Package Manager (PPM) and other module installation methods

XML DOM requires libwww-perl but that is "core" for 5.8.8

I'm running WinXP Pro SP2, ActiveState v5.8.8 binaryBuild 820, ppm4
I need to install XML-DOM package which I've downloaded from ppm.activestate.com and found the other dependencies (that was fun). I'm behind a firewall so don't have internet access thru gui (I set up http_proxy environVariable but it doesn't seem to help).

When I try to install I get this error:

C:\Perl\mylib\XML-DOM-1.44>ppm install XML-DOM.ppd
ppm install failed: Can't find any package that provide libwww-perl for XML-DOM

Package failing to build - Image-Magick

I am wanting to use the FFmpeg package but looking at the available packages from ActiveState shows that this one is not currently building. Following the trail of dependencies, the culprit appears to be caused by an invalid command line argument when building Image-Magick...

Undefined subroutine &DBD::mysql::db::_login

Hi all,
I am installing bugzilla on XP and when I run the checksetup.pl I run into the following error, that I believe has todo with the download of the module:

Undefined subroutine &DBD::mysql::db::_login called at C:/Perl/site/lib/DBD/mysql.pm line 142, chunk 228.

**********************************
Here is a copy and paste of the whole output:
**********************************
Checking for DBD-mysql (v2.9003) ok: found v4.005
Had to create DBD::mysql::dr::imp_data_size unexpectedly at C:/Perl/lib/DBI.pm line 1190, chunk 228.

location for PPM4 repositories

in the dreadful struggle to get net-ssh-w32perl installed, i have lost the location of the activestate repository (and all others except soulcage). the locations i can find on the web are not longer supported due to the SOAP issue. what is the correct location?

New PPM repositories shown empty

I installed ActivePerl-5.8 onto my ubuntu Feisty machine and have had problems adding new PPM repositories to the list.
I can add this repositories to the list, however they always show that there are zero packages on the repository.
Has anyone else seen this and has anyone got a fix for this?

rep add Bugzilla http://landfill.bugzilla.org/ppm

┌────┬──────┬────────────────────────────────┐
│ id │ pkgs │ name │

Installing packages failed service unavailable

When I try to install the template-toolkit and GD packages, the above message in the subject header shows. Is there any way to overcome this problem? Thank you.

Can't find WIN32::ODBC package

I'm running the latest ActivePerl on Windows XP Pro. I want to talk to my SQL Server 2005 database but get errors when I invoke commands to the WIN32::ODBC. I post elsewhere suggested I look in the PPM and re-install the WIN32::ODBC package manually. The thing is when I looked in the PPM, I couldn't find that package, either as installed one, or as one that I could tag for installation. so my first question is how do I get WIN32::ODBC on the list so I can select it for installation?

Need MD5 HASH explained

I am writing some forensic software and I am using the MD5 modual to HASH the files that I copy files from a source drive to a target drive and I need to under stand the HASHing process.

The HASH numbers don't show the same as other HASH programs and I need to document exactly what is happening. Can some one please explain this modual or point me to some documentation on how the files are being HASHed?

Thank you

using PPM::UI to add/del repositories

I have some working code to add / remove repositories from my 'active' list. It uses the PPM::UI functions 'repository_add/del'. Unfortunately these changes aren't being reflected in the output from 'ppm3.bat'. Is there a call I need to make to keep these two sets of values in sync?

PPM can't find DBD-ODBC

Just installed v5.8.8 build 820 on an XP machine, set http_proxy, did a File->Refresh All Data and can't find a DBD-ODBC to install.

Is that package not available for 820?