PPM

Discuss the Perl Package Manager (PPM) and other module installation methods

Perl 5.8 and MD5

I have been having trouble running some of my Perl scripts that use Perl 5.6 using a Win 2000 server on 5.8a Win 2003 Server. It took quite awhile, but I am 99.999999% sure I figured out it is the MD5 module.

Every time I remark it out, my scrfipt works. But, the script was written to use MD5. I use the following line to call it:

use Digest::MD5 qw(md5_hex);

Is there any advice you can give, like, how to see what modules are installed, to be sure it is?

Any help would be appreciated.

PPM4 won't sync - failed 400 Bad Request

Since upgrading from 5.6 to 5.8.8.822, I am unable to sync to the Active State Repository. I am getting the error "failed 400 Bad Request". I have another system on my network that is running 5.8.8.820 which can properly sync.

What I have tried:
1) Uninstalled 5.8.8.822, removed C:\Perl directory, reinstalled 5.8.8.822
2) Uninstalled 5.8.8.822, removed C:\Perl directory, reinstalled 5.8.8.820
3) Uninstalled Norton Internet Security
4) Succesfully added Winnipeg repository and sync'd ok.

Cannot upgrade modules from ActivePerl 5.8.8.822

Hi, I am new to Perl. I have read the forums, Google'd and I have tried to figure this out for 2 days now - I am just not getting it.

I have installed (cleanly) ActivePerl 5.8.8.822
I have installed the free MS C++ compiler
I have installed the free MS nmake utility

5.8.8.822 comes with Mail-SpamAssassin-3.0.2

I need to upgrade this module to Mail-SpamAssassin-3.2.3, and a few other modules that work with it.

I can't for the life of me figure out how to upgrade this module from:

Proc::PID_File Bug

I have upgraded to the latest 5.8.8 build 822, but now I find that the cpan module Proc::PID_File does not work anymore under Windows XP or Windows 2003.
This module checks whether a self process is already running. It is supposed to clean up itself after an exit command. This is not happening anymore. On Perl 5.8.8 build 819 this does work.
Any one have any comments?

Newbie needs help getting modules on Windows...

I am new to ActivePerl under Windows and need some instruction on downloading some modules (LWP, Net, and Crypt) and installing them.
Anyone out there got a simple solution for me?

Weather

Hi

I have installed the Weather::Com module via ppm. However when I type in use Weather::Com in my program I get the error message 'Cannot locate Weather/Com.pmin @INC (INC contains C:\Perl/Site/lib C:\Perl/lib) BEGIN failed -- compilation aborted.'
I don't get any errors on installation, as far as I can tell it has installed correctly, when verifying package no errors are reported.

I am using Komodo personal 4.2 on Windows Media Centre Edition.Everything in the PATH seems to be correct. I also tried this on Komodo 4.1 with the same results.

[Help] DBIx::Class installation error with ppm on WinXP

Hi, when I intall DBIx::Class with PPM on WinXP pro, some error occurs as following:

ERROR: File conflict for 'C:/Perl/html/site/lib/Test/Builder/Tester/Color.html'.
The package Test-Simple has already installed a file that package Test-Builder-Tester wants to install.

I need your help, thanks!!!
realzhang@gmail.com

I need TIE::RDBM - WHere can I get it?

I am trying to load ASSP and one of the Perl Packages it needs is Tie::RDBM. I cannot find it anywhere. It is the last package I need before I turn on ASSP. ASSP = Active Spam SMTP Proxy.

Any help would be greatly appreciated.

PPM can't download package

I just installed on my Win 2000 server, had set the http_proxy system variable as well. When I run my PPM GUI from command prompt, the status of PPM is as below:


Downloading ActiveState Package Repository packlist ... failed 502 Proxy Error ( The ISA Server denies the specified Uniform Resource Locator (URL). )
Downloading Bugzilla packlist ... failed 502 Proxy Error ( The ISA Server denies the specified Uniform Resource Locator (URL). )

Perl module help for windows users

I have been trying in vain to install this XML::LibXML for a while now.

I can install it via CPAN but it cannot find libxml2 so cannot build it. I cannot find the package under my PPM installer.
I have downloaded many Binaries and tried to install them using NMake for Windows. I have copied MSXML2.dll into system32. I have Googled for LibXML2 installation instructions. I have been to PerlMonks, uwinnipeg, xmlsoft etc but still cannot find any instructions.

Does anyone know of a set of instructions for getting, making and installing packages with dependencies under windows.