PPM

Discuss the Perl Package Manager (PPM) and other module installation methods

How to use already compiled dependencies instead of compiling from source ?

I have made some modules on cpan that depend on Gtk2 (or Wx) packages. Compiling these packages from scratch fails most of the time and so the whole build of my modules fails too.

For example
https://code.activestate.com/ppm/Gtk2-Ex-DbLinker/#0.109__MSWin32-x64__5.24

I know that Gtk2 for windows exsist as ppm modules that can be installed without compiling:

ppm install http://www.sisyphusion.tk/ppm/Cairo.ppd
ppm install http://www.sisyphusion.tk/ppm/Glib.ppd
ppm install http://www.sisyphusion.tk/ppm/Pango.pp
ppm install http://www.sisyphusion.tk/ppm/Gtk2.ppd

MSSQL - sqllib.pm &DBlib.pm

I have installed Perl5.24 version in my windows 64 bit machine. My code base is having MSSQL:sqllib module, can someone help me to install or get these library file.

Thanks
Raghu

Can't install Spreadsheet-ParseExcel-Simple in ActivePerl-5.24.1.2402-MSWin32-x64-401627 using PPM

Hi, all,

I want to be able to read an Excel spreadsheet with ActivePerl. I tried to install Spreadsheet-ParseExcel-Simple using PPM, and I get the following message:

Updating files in site area ... failed
Installing 32 packages failed

ERROR: File conflict for 'C:/Perl64/html/site/lib/Spreadsheet/Reader/README.html'.
The package Spreadsheet-Reader-ExcelXML has already installed a file that package Spreadsheet-Reader-Format
wants to install.

I also tried installing Spreadsheet-Reader-ExcelXML with the same results. Please advise how I can make this installation.

PPM ERROR ppm install failed: DBD::SQLite::db selectrow_array failed:

I just installed ActivePerl-5.24.1.2402-MSWin32-x64-401627.exe on Windows 7 as administrator.
Hidden files are enabled for viewing.

I need MIME-Lite and am trying to install the module using PPM.

Command 'ppm install MIME-Lite' reports error as follows:

C:\Perl64>ppm install MIME-Lite
Downloading ActiveState Package Repository dbimage...done
ppm install failed: DBD::SQLite::db selectrow_array failed: file is encrypted or
is not a database

Mail::Sender

Hi,

I'm the current maintainer for Mail::Sender https://metacpan.org/pod/Mail::Sender

I'd like to ask that the current version on PPM be updated to match the current, deprecated version of Mail::Sender out on the CPAN. The release currently in PPM is an older release that contains a bug that ActiveState users have to patch.

Ideally, nobody should be using Mail::Sender at this point in time as Email::Sender (and Email::Stuffer) exist to make your life easier. However, I'd prefer to update the PPM version of Mail::Sender to the one that has this particular known bug corrected.

Net::SSH::Perl and the @INC path

Hi,

Been out of Perl for a little while now, change of job so I need to pick it back up. I have a few old Net::Telnet scripts that I'm converting over to SSH and need the Net::SSH::Perl module.

I can't get it through PPM but I can through CPAN, so using the built in cpan script I upgrade CPAN and pull down all the dependencies for Net::SSH::Perl and the CPAN module itself.

The problem I am seeing is one of PATH for the Include function - @INC is aligned with PPM installs and the cpan module now installs to a totally different PATH that is not multi module aware.

ppm install Excel-Writer-XLSX - failed 500 Can't connect to ppm4.activestate.com:80

I installed ActivePerl-5.24.0.2400-MSWin32-x64-300558.exe.

When I try to ppm the Excel_Writer I get the following:
C:\Perl64\lib>ppm install Excel-Writer-XLSX
Downloading ActiveState Package Repository dbimage...failed 500 Can't connect to
ppm4.activestate.com:80
Downloading ActiveState Package Repository packlist...failed 500 Can't connect t
o ppm4.activestate.com:80
Syncing site PPM database with .packlists...done
ppm install failed: Can't find any package that provides Excel-Writer-XLSX

MinGW package is 404 not found for version 5.24 of PERL activestate.

Hi all,

I cannot install MinGW / dmake right now using Perl 5.24. I am using the command:

ppm install MinGW

The error in the cmd window shows:

Downloading MinGW-4.6.3...not found
ppm install failed: 404 Not Found

This URL below is 404 not found (taken from the ppm log after failure to install):
http://ppm4.activestate.com/MSWin32-x64/5.24/2400/-/--/MINGW/MinGW-4.6.3...

The folder "-" is missing from the site. It is present in previous versions of the PERL folders (5.22).

Perhaps this folder has been deleted by accident? Or am I making a mistake?

MIssing package in new versions (Bot-BasicBot)

As per this (http://code.activestate.com/ppm/Bot-BasicBot/) which is not up to date to 5.24, but it shows Bot-BasicBot (IRC bot framework) is dropped from 5.22 (and not showing up for me in 5.24). I'd use 5.20, but the community version is no longer downloadable. The log from 5.22 build shows, to my amateur eyes, the build was ok, but the test run over time and the job was aborted? Are there any options to download 5.20 again, or otherwise get Bot-BasicBot installed?

Perl version 5.24.0 - Unable to access repository

I am having problems running PPM on my corporate laptop after installing the 64bit version of perl - Version 5.24.0.

I get the following error when I run "ppm install Tk" from an admin command prompt:

H:\>ppm install Tk
Downloading ActiveState Package Repository packlist...failed 500 Can't connect to ppm4.activestate.com:80
ppm install failed: Can't find any package that provides Tk