PPM

Discuss the Perl Package Manager (PPM) and other module installation methods

PPM for Perl 5.8 is Frozen

PPM services for Perl 5.8 are outdated, and should not be used.

The final update for all 5.8 PPM3 based systems was September of 2009. All 5.8 PPM3 servers have been decommissioned since 2010.

Date of last 5.8 update for PPM4 based systems:
Windows 32-bit - March 2010
Windows 64-bit - Never Supported
Linux 32-bit - March 2010
Linux 64-bit - March 2010
OS X - March 2010
Solaris 32-bit - March 2010
Solaris 64-bit - Never Supported
Solaris Intelx86 - Never Supported
AIX 32-bit - Never Supported
HPUX RISC 32-bit - Never Supported

The old PPM FAQ

The old-style manuals had a useful FAQ for PPM. It can still be accessed, and still applies with newer version numbers.

http://docs.activestate.com/activeperl/5.20/

Upgrading from Perl < 5.14 using PPM vs upgrading from Perl >= 5.14 using PPM

The documentation for ActivePerl 5.8 through 5.12 still describes a process that only worked when upgrading from 5.6.x, or 5.8.8.817 and older, to a newer Perl.

The CPAN/PPM module "PPM::Profile" is only compatible with Perls using the old PPM version 3.x. It will not create a usable file from a Perl with PPM version 4.x.

Users upgrading from a 5.8 through 5.12 Perl should use a script instead of the old module. Thanks to user "berniec" for posting an example script in the Installation forum:

https://community.activestate.com/node/10420#comment-27084

Net::SFTP & IO::Pty availability

Using ActivePerl 5.26.1.2601 MSWin32-x64

Wanted to download Net::SFTP (version 0.12) for an SFTP task but the module was not available. Your logs indicate the tests had failed back in Sep 2017.

I downloaded the alternative - Net::SFTP::Foreign instead and coded for it. I got a runtime failure owing to a dependency on IO::Pty, which also appears to be broken, as per logs.

Any way to get those resolved ?

Regards,
Mart

ppm install failed: 403 Forbidden

Hi Team,

I have installed ActivePerl 5.26.1 on Windows 2012 R2 x64, IIS 8.5
I have a custom build ASP app which uses Perl.

I need to install a package:
ppm install http://www.comp.rgu.ac.uk/staff/sw/ud/Sentinel.ppd
and i get error ppm install failed: 403 Forbidden

Could somebody help me here... what exactly the problem?

Thanks,
Venkatesh Kanale

ppm gui failed: DBI connect

If the name of Windows user is not written in the Latin alphabet (I have Cyrillic), then ppm produces such an error. How to avoid it?

c:\>ppm
ppm gui failed: DBI connect('dbname=C:\Users\????\AppData\Local/ActiveState/ActivePerl/2404/ppm-MSWin32-x64-multi-thread-5_24.db','',...) failed: unable to open database file

Trying to Install PAR-Packer

Hello,

I am trying to add some new packages to my Perl Installation. I was successfully able to add the PostScript-Convert package However, when I try to install the PAR-Packer package, I get the error message:
ppm install failed: Can't find any package that provides PAR-Packer.
I am using the command provided by the ActiveState PPM Index so I am not sure what is going on. Any suggestions or help would be appreciated.

Regards,
Jim Crust
Elliott Company

ImageMagick fails on accessing registry key (Exception 495: RegistryKeyLookupFailed `CoderModulesPath' @ error/module.c/GetMagic

Exception 495: RegistryKeyLookupFailed `CoderModulesPath' @ error/module.c/GetMagickModulePath/664

Perl: ActivePerl-5.26.1.2601-MSWin32-x64-404865
ImageMagick: ImageMagick-7.0.8-11-Q16-x64-static
ppm install PerlMagick

First note - The dynamic version of ImageMagick crashed on being unable to load the dll. That's why I switched to static.

A simple test script trying to read a .GIF produces the error above.

Thanks

Unable to use ImageMagick with 5.26

Perl: ActivePerl-5.26.1.2601-MSWin32-x64-404865
ImageMagick: ImageMagick-7.0.8-11-Q16-x64-dll
ppm install PerlMagick

I get the Dynaloader error with respect the image magick dll. Is there a fix?

SOAP-Lite not available in PPM

Anyone know why SOAP::Lite is not available in the ActiveState repository?

Trying to upgrade our systems to the current 5.26.1 version of ActivePerl, but SOAP::Lite is required by an application we must have.

I tried to install it using CPAN also, but the result was not usable (many compile issues on "require")

Thanks