PPM

Discuss the Perl Package Manager (PPM) and other module installation methods

The old PPM FAQ

The old-style manuals had a useful FAQ for PPM. It can still be accessed, and still applies with newer version numbers.

http://docs.activestate.com/activeperl/5.20/

Upgrading from Perl < 5.14 using PPM vs upgrading from Perl >= 5.14 using PPM

The documentation for ActivePerl 5.8 through 5.12 still describes a process that only worked when upgrading from 5.6.x, or 5.8.8.817 and older, to a newer Perl.

The CPAN/PPM module "PPM::Profile" is only compatible with Perls using the old PPM version 3.x. It will not create a usable file from a Perl with PPM version 4.x.

Users upgrading from a 5.8 through 5.12 Perl should use a script instead of the old module. Thanks to user "berniec" for posting an example script in the Installation forum:

https://community.activestate.com/node/10420#comment-27084

PPM crashes after fresh install of Perl 5.16.3

On my Win 7/64-bit system, I did a clean uninstall of AS 5.16.1/64-bit, then a clean install of AS 5.16.3/64-bit.

When I then tried to run PPM, it immediately crashed.

I uninstalled, rebooted and reinstalled, same crash.

I uninstalled, deleted C:\Perl64 directory and then reinstalled, same crash.

I'm going to try 5.16.2 now. Any other suggestions?

Rick

PPM Access for Business Edition ActivePerl versions

There is an FAQ posted under the ActivePerl heading regarding 401 Authorization messages generated by PPM.

http://community.activestate.com/faq-list?tid=50

SOAP-Lite not available in PPM

Anyone know why SOAP::Lite is not available in the ActiveState repository?

Trying to upgrade our systems to the current 5.26.1 version of ActivePerl, but SOAP::Lite is required by an application we must have.

I tried to install it using CPAN also, but the result was not usable (many compile issues on "require")

Thanks

mod_perl-2.0.ppd installation failed

When I try to install a mod_perl-2.0.ppd with command line:

ppm install http://theoryx5.uwinnipeg.ca/ppms/mod_perl-2.0.ppd

I am getting this error:

ppm install failed: 500 Can't connect to theoryx5.unwinnipeg.ca:80 (nodename nor servername provided, or not know)

Active perl version is 5.24.3. URL is unreachable in browser, so this repository no longer exists.

Can anyone help me fix this or to find appropriate repository ?

dbd-sqlite 1.56 build for perl 5.18 windows & linux 64-bit

DBD-SQLite came out with version 1.56. I was wondering when we could expect it to be built for perl 5.18 for Windows and Linux 64-bit. I couldn't find any information on the normal build schedule. Thanks for any information!

Alien-wxWidgets 0.68 in PPM is incomplete

I encountered a situation a few days ago where Wx 0.9928 would no longer load in 5.22 Win10 x64. After doing some digging today, the problem seems to be the build of Alien-wxWidgets 0.68 in PPM is incomplete. The Config and Msw libraries are absent, and from the PPM log, they not being built. Alien-wxWidgets 0.67 was built correctly, but it is now locked in PPM. I have one machine that still has 0.67 on it, and it works fine.

Ron

Inlne-Java-0.63 Perl loader can't find C:\Perl64\site\lib\auto\Inline\Java\JNI\JNI.dll

Is Inline-java-0.63 compatible with 64 bit perl 5, version 24, subversion 3 (v5.24.3)?

The JNI.dll in fact is in the correct path but the Perl DynaLoader says it can't find it there.

Otherwise, this version of Inline-java, built from meta::cpan appears to be healthy:

https://metacpan.org/pod/Inline::Java#JNI-vs-CLIENT/SERVER-MODES

Thanks;
Allan

WX from PPM 5.22 Win10 x64 won't load

Some software that ran under 5.22.1 about 2 years ago now fails. Everything works except the WX package from PPM now fails at the "use Wx;":

Can't load 'C:/Perl64/site/lib/auto/Wx/Wx.dll' for module Wx: load_file:The specified module could not be found at C:/Perl64/lib/DynaLoader.pm line 194.

Several programs exhibit the identical problem. I upgraded to 5.22.4 x64; no change. The dll file definitely exists; DynaLoader doesn't like it.

Any ideas?

Ron