PDK Support

Installation Problems and FAQs for Perl Dev Kit

Thinking about an upgrade?

Please see this FAQ on which ActivePerl releases are compatible with the final release of PDK.

https://community.activestate.com/faq/finalversionpairingsPDK

PDK applications are aborted when 5.24 ActivePerl is used

Using ActivePerl 5.24.0 Build 2400 (64-bit)
& PDK 9.5.1 (64bit) on Win 7 64-bit.

when I try to launch perlapp, it will say "C:\Program Files\ActiveState Perl Deve Kit 9.5.1\bin\perlapp.exe is not recognized as a PDK tool" as attached picture

Any help is much appreciated.

PerlNet v9.5.1 on 64bit WinSrv2012R2 This assembly is built by a runtime newer than the currently loaded runtime and cannot be l

Hi,

I'm migrating from a WSUS 3 installation on Srv2008 to the native WSUS role of a WinSrv2012R2.

However, I do not get the script running, because:

+ in order to get plc running, I had to install .Net v3.5,
+ when I try to compile a script I get:

PerlNET 9.5.1 build 300018
Copyright (C) 1998-2016 ActiveState Software Inc. All rights reserved.
Commercial license for ...

libperl.so missing or wrong version found on Linux

Have a development CentOS box that I've created a binary to run on another Linux box that did not have perl. All worked well up until recently. The runtime box was recently updated. It now has Perl 5.8.8 (non-activestae build) and some other pkg updates... but it is still basically the same OS (32bit CentOS 2.6.18).

Now when the binary is executed it reports libperl.so found at /usr/lib/perl5/... not an ActiveState binary. Which is true.... but what is this an issue now?

the /tmp gets the pdk-xxxx/ dir with the libperl.so from the binary but never seems to be referenced.

Having a Problem? Check here first

Frequently encountered problems may have an FAQ available.

http://community.activestate.com/faq-list?tid=52

pdkdebug.exe missing in 9.1?

I have uninstalled and reinstalled PDK 9.1, but I still can't seem to find the pdkdebug.exe file . I was hoping to install the debugger service. All the PDK 9 docs say the graphical debugger should be there. Am I missing something?

Can't create Executable for other Targets

I use ActivePerl 5.10.1007 for Win32 x86 and the PDK 9.0.1 to make executables from my perl scripts.

This works finde but now i need a linux script and tried to generate one. When i change the Target to Linux (x86) the message "PerlApp doesnt have a cached copy..." comes and PerlApp tries to download the ActivePerl 5.10.107 for Linux. This happens because i reinstalled my development pc with the new windows 7.

But now there comes the Message "Access to ActivePerl-5.10.1.1007-i686-linux-glibc-2.3.2-291969.tar.gz requires an ActivePerl Business Edition licence to be installed".

Where can I find the License Installer for the PDK?

I have installed PDK 9.3 and have the license key.
Where do I get this License-installer to install the key?
Thanks

Service created using perlsvc installs ok and the service starts using -install auto. But the PerlSvc::Startup is not called

I'm using PDK 9.5 and I have create a service using PerlSvc. The service runs OK interactively but when I execute the exe with -install auto, the service installs and successfully starts, but the PerlSvc::Startup function I have defined is never called. How can I trouble shoot this and why wouldn't that function be called?

PDK only compatible with Perl build 2201 -- where to get it?

Hi, since PDK 9.5.1 will be the final version and it is incompatible with Perl builds after 2201, would it please be possible to offer build 2201 as a download -- at least for awhile longer for PDK owners? Thanks!

Kyle