PDK discussion

Perl Dev Kit usage questions; Perl Dev Kit practices and project questions

Can't find perl516.dll....

I just purchased the DevKit (9.21) and tried a very simple test. I am running perlapp on a 64Bit Ubuntu machine but compiling for Windows 32Bit OS. On first run the app goes and downloads the required Windows cache and then creates the executeable without error. However, when I try and run this on a Windows machine (I have tried many) I get this error:

Error: Can't find perl516.dll. Make sure the ActivePerl bin directory is in you PATH.

I configured the app to be an independent executable so I assumed it would wrap the required dll's into the exe.

PerlApp does not find Tk module - Perl 5.14.2 and Trial PDK

Hello,

I’m using a trial version of PDK and ActiveState’s community version of Perl 5.14.2 (which I understood is still being supported by the community). My code includes Tk module (version 804.030) from CPAN that I installed with PPM. I was able to create an executable that runs on my native Windows 7, 64-bit system using the PerlApp GUI.

PerlApp - Getting a backtrace from a coredump

Hello All!

How can I get a backtrace of segfault application packed with perlapp?
My application sometimes dies with core file. How can I analysis it?

[root@ndRR3 cknm36]# gdb -c core.25625 /usr/local/bin/myapp
GNU gdb Fedora (6.8-27.el5)
Copyright (C) 2008 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law. Type "show copying"
and "show warranty" for details.

SplashScreen Feature Request

I have two large projects with many bound files. Because this the executables need up to 8 seconds from clicking till the gui is shown.
Is there a chance that AS include a spashscreen feature so that we can set a bitmap that is shown while perlapp extract the interpreter and the bounded files?

Pack Win64 PerlSvc using Win64 lib break

Using a Win32 perl distribution:
- pack library with Win64 perl
- pack PerlSvc with Win64 perl, --use on pack library

The library pack runs OK.
I receive the following error on the PerlSvc pack:

PerlSvc 9.1.1 build 295479
Copyright (C) 1998-2011 ActiveState Software Inc. All rights reserved.
Commercial license for XXXXXXXXXXXXXXXXXXXXXXXXXX

Invalid type 'Q' in pack at /Config_heavy.pl line 1233.
BEGIN failed--compilation aborted at IO/Handle.pm line 266.

- pack library with Win32 perl

How to decomplie the souce code from *.exe which compiled with perlapp?

I'm a poor guy that lost the harddisk with the latest source for two extremly important scripts and only got the exe files left.
Is it possible decomplie exe file to source code?

Hope get your help.

Thanks very much.

Frank.

PerlNET class constructor(?) equivalent syntax question

Greetings,

After a long period of resistance I find myself having to follow a vendor's app into the world of .net. Perl has been so good to me for years now, in parsing and manipulating complex CAD data and I have a lot of code I would much prefer to re-use and not re-write in c# :-\

The problem I have is in figuring the constructor/initializer start block required by the application. Sorry if my terminology is off on what this block is called.

The template code provided is this:

namespace ScriptSession
{
   
    public class Script
    {
        /*
           Notes:

--target windows-x86-32 unable to locate Log::Dispatch::Win32EventLog

When using PerlApp 9.2.1 & Perl 5.16.1 for 64-bit, I am creating an executable targeted at 32-bit machines: PerlApp seems to be able to collect most of the 32-bit pieces it needs into it's cache with the exception of Log::Dispatch::Win32EventLog.

Command:

PerlTray with Windows UAC issue

Hi, I have written a small program using perltray on Windows 7. Basically, this program ping several hosts display the response time on popupMenu. This works fine on my PC. But when I copy the program to another windows 7 machine, it does not work. I need to enable "run as administrator". With that checked, I get another issue when I run the program on other machine, it keep saying:

Do you want to allow the following program from an unknown publisher to make changes to this computer?
Program name: myperltray.exe
Publisher: Unknown

warning while building perl application : warn: Can't locate VMS\Feature.pm

Hi,

I am getting a warning message ( warn: Can't locate VMS\Feature.pm ) while building our application with PDK 9.2.1 BUILD 29643.It's just a warning and allowing applications to be created. I just wanted to know whether this will impact our executables in any way, so that we can decide whether to give it to our customers or not.

I would also appreciate if i know the reason or any step to fix this warning.
Quick reply is appreciated.

thanks,
Sanjeev Gattu