PDK discussion

Perl Dev Kit usage questions; Perl Dev Kit practices and project questions

Perlapp and DateTime::TimeZone

Unfortunately I'm confined to an old ActivePerl (5.12) and a fittingly old PerlApp (9.2.1).

There seems to be an issue with newer releases of DateTime::TimeZone, such that perlapp adds all the timezone pm files (it's visible with --verbose for example), but regardless the application cannot find it.

Perlapp fail when compiling for Mac OS X on Windows 7

I have made many Mac builds from my Windows machine over the years, but now it is failing. I've tried all sorts of --trim and use commands but with no luck. Can anybody help me figure out what is going on?

The script compiles fine for Windows, no problems. The failure is below. THANKS!

Updating files in target-site area...DBD::SQLite::db do failed: constraint failed
column path is not unique at /ActivePerl/PPM/Ins
tallArea.pm line 562.

PerlNET and System.__ComObject

I'm wrapping an existing perl module with PerlNET. Additionally, I've written a simple method (+ pod interface declaration) to be able to set the value of an existing global variable $Lib externally.

    our $Lib;
    ...
    =for interface
        void SetLibVariable(object value);
        ...
    =cut
    ...
    use strict;
    use Win32;
    use Win32::OLE::Variant;
    ...
    sub SetLibVariable {
        my ($self, $value) = @_;
        $Lib = $value;
    }

Now I have the following problem:

PDK

After converting a .pl to an .exe to run as a Windows service using PerlSvc (PDK-9.4.0 and ActivePerl-5.20.2) I get a test error "ERROR LOADING MODULE: Date::Manip::DM6 at C:\Perl\NCx86.exe>Date/Manip.pm line 35". I tried adding "BEGIN {$Date::Manip::Backend = 'DM6';}" and "use Date::Manip;" under it at the beginning of the script to no avail. I have re-loaded the module and everything else and have been reading related articles for days and have yet to find an answer to this problem. Please help?

PerlAPP Problem to hidden $0, and arguments.

In my source code .pl, I put the following code to change the value of $ 0 to change the arguments:
($ 0 = "$ 0argv") = ~ s / p \ s + \ w + \ s / x /;

This works for me to run normally With PERL, but when I package with PerlApp, just change the name of the process and maintains the grounds. I need to change everything with arguments.

Someone could help me?

PerlTray does not show balloon notifications or timers

I am checking out the sample.pl in perltray. everything works except for ballons and timers. i am using windows 10 as well and do not have a way to test win8 or win7. Does anyone have any insight as to why its not working?

MSI creation failed on Win32

Hi,

we build an msi on a windows7-64 Bit successfully. Our client needs an 32-Bit version, so i build the whole source tree on a 32 Bit Windows. Everything is fine, but the last step is failing: We can't pack all into an msi archive.

The error i get is:

Can't load 'C:\Program Files\ActiveState Perl Dev Kit 9.4\lib518/auto/MSI/Util/Util.dll' for module MSI::Util: load_file
:A dynamic link library (DLL) initialization routine failed at C:/Perl/lib/DynaLoader.pm line 191.
at C:\Program Files\ActiveState Perl Dev Kit 9.4\lib518/MSI.pm line 5.

Run time error 'Can't locate (perl) object method' under Visual Studio 2013 C#

I just installed PDK under Win 7, with the latest ActiveState Community perl 64 bit. I'm trying to wrap my first perl code into a DLL so I can use Visual Studio 2013 Express to build a nice gui, with the Perl code tied in, but am getting a strange run-time error as follows:

I have this 'test_perlnet.pl' file :

use warnings;
use strict;

# Putting the following 'use Log::Report' line here (before the package
# and subroutine definition below) causes a Visual Studio
# run time error when I try to call 'do_some_thing()'

PerlApp 9.1.1 Error: Can't find PerlApp 0.0 - Why is it looking?

Using the PerlApp GUI 9.1.1 on Windows 7 32 bit. When I click the 'Make Executable' button, I get the following:

PerlApp 9.1.1 build 295479
Copyright (C) 1998-2011 ActiveState Software Inc. All rights reserved.
Commercial license for Helen Hogan

SetDualVar.pm:
warn: Can't locate SetDualVar.pm
refby: C:\Perl\lib\Win32\TieRegistry.pm line 39
VMS\Feature.pm:
warn: Can't locate VMS\Feature.pm
refby: C:\Perl\lib\File\Copy.pm line 49
refby: C:\Perl\lib\Cwd.pm line 211

Cross Compile for Linux z86 (32/64) requires glibc 2.5 which is not available RHEL 4

I have the PDK version 9.3 build 297998 installed on my Windows 7 Pro machine. When I cross compile for linux x86(64) and try to run the binary in RHEL 4 it abends with this error.

[root@tm1linuxbuild ~]# cat /etc/*release
Red Hat Enterprise Linux AS release 4 (Nahant Update 7)
[root@tm1linuxbuild ~]# uname -a
Linux tm1linuxbuild.swg.usma.ibm.com 2.6.9-78.EL #1 Wed Jul 9 15:26:38 EDT 2008 x86_64 x86_64 x86_64 GNU/Linux
[root@tm1linuxbuild ~]# ldd ./SCMonGIMInstall_Linux-x86-64
not a dynamic executable
[root@tm1linuxbuild ~]# cksum SCMonGIMInstall_Linux-x86-64