PDK discussion

Perl Dev Kit usage questions; Perl Dev Kit practices and project questions

Where to start with compiling an exe???

Hello

I am trying to create an exe from a perl script.

ALL of the instructions give you the code EX: perlapp myscript.pl --add IO::Socket --add XML::Parser::Expat

but where do I run this?? From the CMD prompt.

Perlapp mac osx build drag and drop support

Hi,
I regularly mac PC and Mac executables from my PC using Perlapp. When I make a PC executable, it is drag and drop, passing any dragged item into @ARGV, and it works great.

For Mac builds, I can't seem to get this to work, and I have to wrap the build in an Applescript in order to enable this functionality. I'd love to avoid having to do this every time. Is there any way to do this from Perlapp itself, like for PC builds? I've tried the -gui flag but that doesn't do it.

Thanks!

system command doesn't execute with option --gui

I wrote a script with Tk gui that starts another program with the "system" function.
This works well when i build it with perlapp and i don't use the gui option.

When i want to hide the console and build it with gui option, the whole app is stopping and hangs up.

I use Win7, Perl 5.16 x86 and PDK 9.5.1.

How can i start an app out of my Tk Script?

PerlApp created executable not running with nonexec permission on /tmp directory

Hi,

We are using PerlApp to create freestanding executable from perl script.
When the executable built with PerlApp runs, it extracts its dynamic object files in the /tmp/pdk directory. However, it is not working on those systems which have some security permission like nonexec and non writable on /tmp directory.

Our application run on different ports and the problem is same on Window,Linu and AIX platform.

PDK RoadMap

Hi,

We have been using PDK extensively at our company.

When will the PDK support for perl 5.24 x86 will be available?

Can you pls share the roadmap for PDK? This would help us to plan to purchase of PDK in upcoming years and keep the perl deployment strategy.

Thanks,
Bakkiaraj M

perlapp --bind LD_LIBRARY_PATH not working for use statments module load inside application

In trying to make an application which uses XML::LibXML portable in regards to system shared libs version I installed the XML::LibXML module and built is against my own version of the libxml2 shared library.
here is the test perl snippet (with some pause for user input for troubleshooting) :
-----------------------------------------
print "ENV = \n";
foreach my $key (keys(%ENV)) {

printf("%-s: $ENV{$key}\n", $key);

}
print STDERR "Hit Enter > "; scalar ;

use XML::LibXML;
##use XML::Parser;
print STDERR "Hit Enter > "; scalar ;

PerlApp DateTime::Format::ISO8601

In an effort to compile a larger script I was running an error after running the compiled executable. I have narrowed it down to the use of the DateTime::Format::ISO8601. As such I have a script that just has the use of that module in it and nothing else:

use DateTime::Format::ISO8601;

If I put this into PerlApp i get the following error:

The following parameter was passed in the call to DateTime::Format::Builder::Parser::create_single_parser but was not listed in the validation options: regex
at /DateTime/Format/Builder/Parser.pm line 164.

PerlApp Icon source - can't find package ico 0.3

I can add an icon within PerlApp but I get the error as shown below.

1461817487_Blue.ico

The file icons\1461817487_Blue.ico contains the following 1 icon:

1: 128x128, 32 bits [can't find package ico 0.3]

My application compiles and runs but there is no icon in the EXE.

PerlApp version 9.5.1 build 300018

Thanks!

Running a method from a shared, but not bound, PerlApp generated exe

I've written a Perl script which invokes various class methods written as their own packages in their own ".pm" files in the same directory.

For various reasons I am not able to predict which classes will be required when the script runs so the following code dynamically requires the modules when needed:

for (@classes) {
        unless (is_loaded($_)){require $_ . ".pm"};
}