License installers

My license installer for Komodo ver 8 won't run on macos Mojahe.

I just just did a clean install of macOS X Mohave and thus lost all my installed software. I am trying to reinstall Komodo, I have version 8. I know there are newer versions but there isn't an upgrade path from the Personal License and I don't use it enough to buy it over again just to have a new version. Anyway, Komodo installed find and would seem to run okay but the license installer (I just redownloaded it from my account to make sure I had the most recent one if there were changes) and it won't run.

Having a license problem? Check here first:

Frequently encountered problems may have an FAQ available.

License installer's downloading be blocked by Windows Defender

I tried to download license installer of Komodo Personal 11 for windows, then Windows Defender blocks it.
And it reports that 'Trojan:Win32/Spisky.U!cl' is detected.

I downloaded it on my Mac, then I move it to OneDrive, but Windows 10 denies sync to pc's storage.

How to install my license ?

I followed the FAQ but the license installer is no where to be found.

Windows 10 License Installer does nothing?

I have been attempting to install my license for Komodo IDE to my windows 10 computer but whenever I attempt to run the installer nothing happens other than the .exe being removed from my computer. I tried to verify that the license was installed by checking in this location C:\Users\\AppData\Roaming\ActiveState\ActiveState.lic as this link shows where it is

ActivePerl Business Edition Silver


I'd a ActivePerl community edition installs on Windows(TEST server), and just purchased Business Edition license. But I'm a bit unclear about converting Community edition to Business edition, because when i did Perl install, just ran .exe file and don’t remember the install asking for a License key. And I couldn’t find any documentation on Perl license activation, Do I need to uninstall existing one, and re-install Business edition? Please advice.


Licence not activated under Ubuntu 16.04 LTS


I have a commercial license for Komodo IDE. I have just installed Komodo under Ubuntu 16.04.1, accepting a trial license. After that I have downloaded the license activation script and tun it with root privileges (sudo). The script says "ActiveState license installed successfully" but Komodo IDE still says I am running the trial license and I have 19 days left ...

Can you please advise ?

Best Regards,


Moving licenses from Win7-32 to Win10-64 (same machine)


After too much thought and planning I finally gave up win7-32 and moved to win10-64. For the time being I want to keep win7-32 in a separate disk and I already fresh installed win10-64 in another disk SAME computer using dual boot. Right now I'm in the process of installing all the programs that I need in win10.

I just paid for an upgrade and downloaded the program and license but I haven't installed anything yet.

My questions:
1. The most important question. Will I be able to run from both hard disks?

How many installs is one license good for

how many devices can a user have Komodo installed on, per license agreement?

Where to put License Key in Perl Dev Kit Trial version ?


My company has purchased License key for Perl Dev Kit, but when I installed the software and on launching it gives a pop with 21 day trail option only.Please help me as to how and where can I put the License Key in the Trail version installed software? Is there a seperate installer for each license purchased?