Installation Support for ActivePython

Installation Problems and FAQs for ActivePython

Having a problem? Check here first:

Frequently encountered problems may have an FAQ available.

Can't install ActivePython 3.6 on Windows 10


I'm trying to install ActivePython 3.6 on my Windows 10 machine for the first time. I'm running the installer "ActivePython-" with the default installation options.

The installer seems to run as expected. It runs for a minute or so and then displays a message "Completing the ActivePython 3.6.0 Build 3600 (64-bit) Setup Wizard." I then click the "finish" button and the installer exits.

old version

I have a software requirement for version 3.1 of active python -- does anyone know where I can
find this download?

ActivePython 2 and ActivePython 3 for WinXP SP3 32bit and Win7 SP1 64bit


I had no idea there were different ActiveState Pyhton typologies (i.e. FirstClass and "regular").

1) Where can I get the latest "regular" ActiveState Pyhton 2 for 32bit Windows XP SP3 and for 64bit Windows 7 SP1?
2) Where can I get the latest "regular" ActiveState Python 3 for 32bit Windows XP SP3 and for 64bit Windows 7 SP1?

and here
I can read "ActivePython requires Windows XP, or later.".

Thank you! for 32bit, x86 Windows

Here I currently don't see an installation file of ActivePython for Windows x86 32bit (Windows XP in my specific case).
Here I can read that Windows XP is OK with 2.7.13.
Can someone help?

Import errors using ActivePython on MacOS Sierra V10.12.5 with packages such as tensorflow, sklearn

ActivePython (ActiveState Software Inc.) based on
Python 2.7.13 (default, May 16 2017, 11:18:28)
[GCC 4.2.1 Compatible Apple LLVM 6.0 (clang-600.0.57)] on darwin
Type "help", "copyright", "credits" or "license" for more information.

>>> import tensorflow
Traceback (most recent call last):
File "", line 1, in
File "/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/site-packages/tensorflow/", line 24, in
from tensorflow.python import *

ActivePython Windows .bat all broken

Just installed the lastest version of ActivePython on my Windows 10.
Can't use any off ipython, jupyter, ... out of the box from a cmd.
Please help me finding a global solution to my problem,
I only succeeded to "hack" the install.


Fired a cmd.exe shell.

> ipython
echo off
python.exe non module ipython found.

Same for almost every packages I tried.

First thing:
Please put an @ before "echo off" to avoid prompting => "@echo off"

Second thing:
All .bat shortcuts seems to be broken.

Python install immediately fails

I had AP installed and running just fine. I d/l'ed 2715, and tried to install it after uninstalling 2714 and rebooting. I removed c:\python27 completely.

All options (Typeical, Custom and Complete) immediately exit with an error and no system changes. I d/l'ed another copy, and it is identical to the first copy.

I obtained another copy of 2714, but it likewise ends prematurely with an unknown error.

Any suggestions? There is plenty of disk space, so that's not the problem.

ActivePython 3.4

I am developing a MySQL application. From what I can see, MySQL only supports Python 3.4. What is the last ActivePyton release of Python 3.4 and where can I get it?

Installation failed on OSX Sierra

Here is the installer log showing errors.

Does this help anybody to understand what's wrong?

Mar 17 22:19:19 ysteins-iMac Installer[3704]: Installation checks succeeded with warnings.
Mar 17 22:19:19 ysteins-iMac Installer[3704]: Installation check warning. An existing installation has been found on your system. NOTE: Detected an existing installation of ActivePython 3.6 on your system. Please consider uninstalling it before proceeding with the current
installation. Please check the documentation for more information..