Installation Support for ActivePerl

Installation Problems, Installer content, and FAQs for ActivePerl

Missing documentation


I have installed Activeperl 5.16.1 on two PCs. Both run Windows 7 but one is 32bit and the other 64bit. I have installed the correct version of Activeperl on each.

However, the 64bit version is mission a lot of documentation, including the core documentation. The 32bit version seems fine.

This is a nuisence, as I do not always have an internet connection.

Make work around is to copy the 32bit documentation, but it would be nice if the install provided all the documentation.


Installing ActivePerl v5.1x x64 bit on Windows Vista x64 and Issue

When I try to install ActivePerl (v5.14 or 5.16) x64-bit using the msi installer
on a Windows Vista x64 I have the following problem:

Perl complains that cannot find the file in the lib directory.
Indeed this configuration file is not created. However the still is created. I am not so expert to create myself.

Could somebody please tell how to resolve this issue?


PPM and PerlCritic GUIs crash after upgrading to ActivePerl-5.16 on Mac OS X 10.8.1

Command line works fine for both. ActivePerl-5.14 worked fine. Re-installed lastest ActiveTCL

Perl Critic fails as follows (PPM crash output will follow below):

Process: perl-dynamic [2981]
Path: /usr/local/ActivePerl-5.16/bin/
Identifier: com.activestate.perlcritic
Version: 10.00 (10.00)
Code Type: X86-64 (Native)
Parent Process: launchd [490]
User ID: 501

Date/Time: 2012-09-12 15:12:39.605 -0400
OS Version: Mac OS X 10.8.1 (12B19)
Report Version: 10

is community edition free?

I need Perl to connect to Oracle & extract data in text format.
Would appreciate if you can let me know whether the Perl Community Edition will help. Got to know this is a free version and won't need a liscense. Is that true /

Raj Nair

HTML Users Guide not updated with PPM modules, and missing sections

I recently added a new package with PPM, and was looking for the documention. New packages downloaded with the PPM should show up in the ActiveState User Guide, on the left pane contents, but there just seems to be a lot missing, including the new package (Hash::Case). I have only 6 of the 300 packages installed, nothing under Core, 1 pragma, 2 programs.
Can I fix this and get the documentation to the installed packages and core?

As a workaround, can I find the HTML PPM said it was generating somewhere? I've looked at C:/Perl/lib/site but it's not there with the pm.

PerlScript support for Windows Server 2008 64 bit servers


I'd like to use PerlScript scripts with Solarwinds to leverage Perl to create clever application monitors that report their findings to Solarwinds Server and Application Monitor. Solarwinds will only run Perl via Windows Script Host, so I have to use PerlScript.

ActivePerl 5.14.2 Build 1402 (64-bit) change installation directory to c:\Program Files\Perl64 on Windows 7 64-bit

Having an issue with the ActivePerl- I am trying to configure the msi to install the files to the 64-bit Program Files folder in Windows 7 64-bit. The msi either installs to Program Files(x86)\Perl64 or C:\Perl64, but not in the 64-bit directory.

installation issue with Active Perl on Windows Server 2008 R2 Enterprise SP1


it's the first time I post it and the first time I can't install active perl on a server.
Sorry first for my english style.

I want to install activePerl on a Windows 2008 R2 SP1, we could do it on Prod environment
but doesn't work on staging.

I just launch the msi file and just after making the choices, it just end abruptly.

I did already see some forums, telling we had to be on c: locally on server, but still the same issue.
You surely already answered this question, but didn't find it already.

I could install with a log.

Installing ActivePerl on OS X Lion

Hi, I may eventually figure this out, but I cannot get the manual part of the installation process to work. I am stuck at the configuration part. OS X Lion. I am trying to do this as a student/novice, because my system Perl did not perform as it told me none of the documentation was in existence, and I couldn't get on to the second exercise after "hello World, " in LEARNING PERL. It actually said that there was "No documentation found for "perlfunc".

Then, after extensive searching, I found that OSX has defective/incomplete Perl.

Problem with perl path

Hi !

When I execute the command set in the command invit, I'm having 2 path for perl

C:\Perl64\site\bin;C:\Perl64\bin AND C:\Perl\site\bin;C:\Perl\bin

Could you please tell me what it is and how to erase the last one please !