Installation Support for ActivePerl

Installation Problems, Installer content, and FAQs for ActivePerl

No portable version available?

I would like to use ActivePerl occasionally from USB Stick but don't want to install it permanently on a computer.

Is there no "portable" version available for download?


sh fails

when i tried to install activeperl on my Debian 7 box I received the following error: "perl/bin/perl: 1: perl/bin/perl: Syntax error: Unterminated quoted string"

Please advise how to fix.

Installing ActivePerl (64) under "Program Files" disallows updation

I installed ActivePerl under "C:\Program Files\" and when I run PPM it just doesn't update the repository, says there's a permission problem?

I installed it as the System user and have done everything to give Perl64 under "Program Files" read+write permissions, no use.

On the other hand, installing Perl64 directly under "C:\" doesn't have any of the above mentioned problems, just that it's better to maintain a proper hierarchy, hence installation under "C:\Program Files\".

Can someone help?

5.16 1602 install problem - documentation missing

I just installed Perl from the new 1602 install executable, having removed all traces of my 5.14 install. The majority of the documentation appears to be missing. None of the perl516delta files are present, none of the core documentation is showing, and no more than 60 modules are showing in the modules section?

I am loath to install 1601 first as it looks like someone reported a problem with installing 1602 over that.

Incompatible version trying to install 5.16.2 over 5.16.1?

I am trying to upgrade an ActivePerl installation and I keep getting the error message

"The selected directory contains an incompatible version of ActivePerl. Please choose a different installation location!"

I find this difficult to believe because I am trying to install 5.16.2 Build 1602 over 5.16.1. Build 1601 ... seriously, one minor revision cannot be upgraded?

I tried turning on verbose msi logging by invoking the install thusly:

msiexec /i ActivePerl- /l*v ActivePerlInstallLog.txt

Installation Prob: Missing Files? False Directories?

Hey everyone, ill try to keep things simple.
Im running on Ubuntu Linux x64 (i think, but it doesnt matter because i tires 64 and the x86)

I download ActivePerl, extract it to desktop with winrar, then i open my terminal, go to directory and type:
just like the READ-ME says.
When i do this i get this message:


In case the image doesnt go through, i pretty much get spammed with:
- file 'perl/lib/Pod/(somefilename)' missing

No Output When Running Perl Scripts

I have used Active State Perl for a few years on other machines (XP, Vista), but am unable to get Perl to install correctly on my new Windows 7 64 bit machine. When I run a Perl script that outputs to the screen, I see no output. The output screen is blank (no errors appear).

Embarrassingly even a simple "Hello" program won't run.

I'd appreciate any help.


Unable to run perl on windows 7 64-bit machine (DBD::Oracle error)


I tried to run a perl program on windows 7 64-bit machine which is compiled and generated with PDK 8.2.1 32-bit build. It is throwing error as below

"install_driver(Oracle) failed: Can't load 'C:/Perl/lib/auto/DBD/Oracle/Oracle.dl
l' for module DBD::Oracle: load_file:%1 is not a valid Win32 application at C:/P
erl/lib/ line 201.
at (eval 6) line 3
Compilation failed in require at (eval 6) line 3.
Perhaps a required shared library or dll isn't installed where expected
at twconnectsql.perl line 2229"