Installation Support for ActivePerl

Installation Problems, Installer content, and FAQs for ActivePerl

Upgrading from 5.8.822 to 5.16.x

Hello all,

I work for a company which is currently using AP 5.8.822 on their 2003 box and have quite a few Perl scripts. I see in the AS 5.16 documentation, it says build 16xx is incompatible with previous version's binaries, though I'm not sure what that entails.

If we were to upgrade to 5.16.x as I have on my PC, would it break all of the existing Perl scripts written and used in the 5.8.822 environment? I would like to upgrade so I can use the remove_tree function and output to a scalar variable for logging purposes, as opposed to just the spray and pray of rmtree.

Can't locate in @INC

Hi all,

I have been using active state perl for over 8 years.
The person that setup the dev servers have since left.

We purchased the latest version of PDK.
I installed a new server with PDK 9.2.1 and Perl 5.16.3

The PERLLIB ENV is set to c:\Perl64\site\lib and c:\Perl64\lib

When I compile the perl script to exe everything works fine.
When I execute the script I get the following error:

Can't locate in @INC (@INC contains: C:\dev\perl\) at /Net/ line 536

It is almost like the compiler don't add the libraries to the exe.

When will 5.18.2 be released?

I asked this question on various ActiveState forums and in an email to ActiveState support with no reply. I'll try here. Can anybody say when 5.18.2 will be released?

Active Perl support on Solaris 10 X86

Please share the link details where I can download the community edition of Active Perl for Solaris 19 (X86).

linux perl5.16.3 install / run script error

or more to the point, won't run script.
error message;
localhost gary # /home/gary/Perl/ run
bash: /home/gary/Perl/ /opt/ActivePerl*/bin/perl^M: bad interpreter: No such file or directory
localhost gary #

i did the; chmod +x /home/gary/Perl/

The shabang line to; /opt/ActivePerl-5.16/bin/perl
(thats where the perl install lives)

tried to run the bash shell over it to see it;
'perl /home/gary/Perl/'

Recoamimdations from google;

So whats up, how do i run perl script in linux - mint - mate

Install Error Message / Linux

os / debian - mint - mate,

very interesting error message;

I put into the terminal;

localhost gary # /home/gary/Downloads/ActivePerl-

(perl install error,)

env: perl/bin/perl: No such file or directory

Reinstalling 5.16/64-bit

I am among the folks who have seriously broken/missing documentation. My *perl* [and all the packages I've used so far, which isn't all that many of 'em] runs perfectly. But the documentation is decimated [as with everyone else, even the core-components section is missing]. The only "solution" I've seen is a vague-feeling comment that something must have gone wrong with the installation [even though *some* docs are installed, and the actual program is installed], and the fix is to reinstall. such is life...

backticks and system() no longer work

I'm using perl v5.12.4 on a Win7 system

Backticks have stopped working. EG:

$cmd=`dir`; now returns a null string.

$cmd=`file.htm`; used to start the default browser on the named file. It no longer does anything.

System("dir"); similarly no longer works.

The commands work fine if entered on the command line or a batch file without perl.

Can anyone suggest a possible reason for this?

Is there some particular file responsible for handling backticks and system() which I might try to replace?

Is it possible to have unattended install?

I am installing ActivePerl as part of software build on Amazon AWS. Is there a "response file" (yes, I agree with license terms, this is the installation directory, etc) that I could use to avoid manual installation?

Win7 won't pass command line arguments to @ARGV

I installed AS perl on my new Win7 machine, but it won't pass command line arguments to @ARGV.

I suspect it's a registry problem in HKEY_CLASSES_ROOT, but my changes haven't fixed it.

Does anyone know the line to change, and what to put there?