Installation Support for ActivePerl

Installation Problems, Installer content, and FAQs for ActivePerl

Error / bug -- Unable to install packages

I'm using Active Perl and the Perl Package Manager for a project for a grad student. I am using ActivePerk 5.16.2 Build 1602. I'm on Windows 7

I'm trying to install 2 packages, but the "Mark for Install" button is grey-ed out and I can't click (similarly, if I search for the package name and right click it, I see the option to Install it but it is also grey-ed out). The packages I would like to install are for 2.30 and 1.13

Every time I load PPM, I get this window:

Community License Terms

In the context of a code quality reporting toolkit and the recent change in community licensing term for Active Perl, there are few questions that we are faced with:
1. Does the use of Active Perl during the development of an internal quality reporting toolkit still qualify under community licensing?
2. Can the project teams using the toolkit still use community license to use the Active Perl on their internal build machines in order to use the toolkit?
3. What are the approximate pricing for the Enterprise License (~100 installs) and OEM License.

Automated installation in NON-ADMIN environment


I am using ActivePerl in an automated / continous integration system (jenkins).

During the job i try to install ActivePerl on Windows / Linux machines.

This is ok for linux, cause ActivePerl is provided as package, and installer has several commandline options to install as non-root user

On Windows it is hell!

1) Officialy only msi packages are available. I took me some time to detect, that there are also zip files availabe for download. Couldn't these be added to the download page? Or the folder be linked there to get them?

Installer copies files and then --> non-sensical @INC complaints

Running AIX 5.3 PowerPC.

Trying to install Perl (ActivePerl-

File copying works.

Can't locate ActivePerl/PPM/ in @INC (@INC contains: /tmp/perl---------------------------------------------please-run-the-install-script---------------------------------------------/site/lib /tmp/perl---------------------------------------------please-run-the-install-script---------------------------------------------/lib .).
BEGIN failed--compilation aborted.

Install of ActivePerl to /opt/ActivePerl-5.14 failed:

perlis.ddl missing?

I just upgraded to Perl 5.16.3 (on Win 2003) due to an "ActivePerl Heartbleed Security Update" email from activestate. After the upgrade my plx scripts stopped working on my web site. I checked IIS and it was set correctly to map plx to c:\perl\bin\perlis.dll.
I checked and perlis.dll did not exist! I ran the installer again and checked PERL ISAPI and I got: "Use of this feature requires a Business Edition license". WTF!? When did this start? Can anyone help me with this?

Unattended installation to custom directory

I'm trying to automate ActivePerl installations on Windows, referencing the following document: installers

What I've noticed is that the TARGETDIR is actually a base directory. If I want to install the win32-x64 ActivePerl to c:\perl, I can't do that. Specifying a TARGETDIR of c:\perl ends up creating c:\perl\perl64.

Installing ActivePerl on Windows Server 2008 and Windows Server 2012

I am working on migration of a legacy application that uses ActivePerl on Windows 2000 server.
Can ActivePerl run on 32-bit or 64 bit Windows Server 2008 and Windows Server 2012?

Sant T

ActivePerl for Windows 8.1 that uses MSVCR110


I would like to develop a desktop app for windows 8.1 using ActivePerl. The most recent version of ActivePerl 5.18.2 depends on MSVCRT.DLL - as far as I understand MSVCRT.DLL cannot be used in a Windows 8.1 store app, MSVCR110.DLL and related DLLs should be used instead. Since Microsoft is forcing the move to Window 8.1 will ActivePerl for Windows 8.1 be compiled against MSVCR110.DLL and related runtime libraries?

Tomek Wardega

how do uninstall a ActivePerl license from the wrong machine?

this question has been resolved via a support ticket.

ActivePerl 5.18.x persisting bug + packages upgrade script request

I tried yesterday update to newest AP and have not succeed to get it working.
Firstly uninstalled completely previous perl. Then new install to the same directory, and perl is crashing on most of my existing scripts that were working with perl 5.16. I think the bug which was already present in AP 5.18.1 is still present (wrong linkage to perl516.dll). Anyway I didnot manage any of 5.18 perls fully functional and I did update this software many times. So I assume there's something wrong with all 5.18 builds.