Installation Support for ActivePerl

Installation Problems, Installer content, and FAQs for ActivePerl

Install fails with 3 files corrupt

openSuse 13.1 installed with latest updates.

Downloaded the latest Community perl version 5.20.2.2001

Extracted to home dir

Attempted to install. (./install.sh)

The following error comes up.

============

# ./install.sh
Checking package...
- file 'perl/man/man1/c2ph.1' corrupt.
- file 'perl/man/man1/perlbug.1' corrupt.
- file 'perl/man/man1/s2p.1' corrupt.

    This installer package does not have the expected content.  Please
    try to download a fresh copy of ActivePerl from ActiveState's website

5.20.1.2000 64-bit crashing @ IActiveScriptParse::InitNew in PerlSE.dll

ActivePerl 5.20.1.2000 when used as an Active Scripting host from DirectoryOpus (via a Rename function) is crashing in IActiveScriptParse::InitNew in PerlSE.dll.

ActivePerl 5.16.03 64-bit works fine.

If anyone from ActivePerl is listening, and are interesting is reproducing this, I'll supply more info.

install perl64 on windows 2008 R2 and cannot connect to oracle 10g database

hi all,

after I install the perl v5.18.4 64bit, I find I cann't connect to oracle database.

the error message is just like the pic I attach.

when I type PPM in the cmd window. it also accoured error.

Unsuccessful stat on filename containing newline at C:/Perl64/lib/XML/Parser/Exp
at.pm line 19.
Unsuccessful stat on filename containing newline at C:/Perl64/lib/XML/Parser/Exp
at.pm line 19.
...
Can't unlink 'C:/perl64/lib
/etc/ppm-lib
-dirty': No such file or directory at C:/Perl64/lib/ActivePerl/PPM/InstallArea.p
m line 444.

anyone can give me some advice?

Perl516.dll missing

I have just downloaded a later version of Perl and then tried to run one of my scripts and the error message 'The program cant start because Perl516.dll is missing' comes up. Never seen this before after downloading Perl, can any one help please.

Arguments not getting to Perl in 2012R2

Just installed 5.20.1 on Windows Server 2012R2. The product works fine but we're seeing the following weirdness the normal associations are not passing parameters. In fact they were being ignored altogether until we an association in UI as well!

Given:

use 5.12.0;

say join ":", @ARGV;

Let's test it:

F:\temp>showArgs.pl my arguments
 
F:\temp>perl showArgs.pl my arguments
my:arguments
 
F:\temp>assoc .pl
.pl=Perl
 
F:\temp>ftype Perl
Perl="C:\Perl\bin\perl.exe" "%1" %*

Missing DLL during win 7 install

I'd like install activeperl, I keep getting this message:

(see attached)

Would be help id the error said what file is missing

Looking for x64 Perl 5.12 binary

Is X64 Perl v5.12 is available from ActiveState for download?
I want to use Net::Server which is not available AFTER 5.12.

Support for Windows 2012 R2 SE

I am using Windows 2012 R2 SE. Does ActivePerl support this OS? It hangs on "Configuring Perl Package Manager Status. Can anyone help? I am not sure if ActivePerl-5.16.3.1604-MSWin32-x64-298023 package supports Windows 2012 R2 SE.

Sandeep p

Windows 32 bit perl 5.16.3.1604 install doesn't contain "site/lib" in @INC

I've just installed ActivePerl 5.16.3.1604 and when I run perl -V, I see that @INC doesn't include the "site/lib" directory? This is the end of the perl -V output:

Characteristics of this binary (from libperl):
  Compile-time options: HAS_TIMES HAVE_INTERP_INTERN MULTIPLICITY
                        PERLIO_LAYERS PERL_DONT_CREATE_GVSV
                        PERL_IMPLICIT_CONTEXT PERL_IMPLICIT_SYS
                        PERL_MALLOC_WRAP PERL_PRESERVE_IVUV PL_OP_SLAB_ALLOC
                        USE_ITHREADS USE_LARGE_FILES USE_LOCALE