Installation Support for ActivePerl

Installation Problems, Installer content, and FAQs for ActivePerl

ActivePerl 5.24.0 Build 2400 Setup installer freezes when the Install button is pressed

Hi - this doesn't seem right - I've selected Typical Install, clicked on the 'Install' button and the dialog freezes - surely I should get some kind of progress bar?

Need to reinstall ActivePerl on Windows 2008 Server VM

I have installed ActivePerl on Windows 2008 with MSI from exe on the wrong Directory C drive rather then D drive. Best way to resolve issue can I repair, modify or do I need to remove it? Then I would also need to delete directories created during installation of ActivePerl ? Thanks Doug

How to Get Perl to Automatically Look in Specific Directories for Scripts?

I have ActiveState Perl installed on a Windows machine.

Now, suppose I have scripts, including one called "SomeScript.pl", in this directory:

"C:\Example\Foo\Bar\"

How do I configure Perl to automatically look in that directory for scripts when it is passed a script path?

For example, from the command line, I can run...:

perl C:\Example\Foo\Bar\SomeScript.pl

...just fine.

But the following...:

perl SomeScript.pl

Perl installation error

Hi, I tried to install ActivePerl on Linux ( 64 bit ). I got the following error.

perl/bin/perl: /lib64/libc.so.6: version `GLIBC_2.14' not found (required by perl/bin/perl)

Please let me know the solution.

Thanks,
Chaitu

License question for research use

Would use of ActivePerl for life science research (running the Trans-Proteomic Pipeline software) on a US government campus fall under the community license or would a business/enterprise license be required?

Thanks,

-Tom

Trojan.Dropper.Heur.gen / W32.eHeur.Dropper in ActivePerl-5.24.0.2400-MSWin32-x64-300558.exe ?

The file downloaded from https://downloads.activestate.com/ActivePerl/releases/5.24.0.2400/Active... has SHA256 of 9e6ab2bb1335372cab06ef311cbaa18fe97c96f9dd3d5c8413bc864446489b92.

https://www.virustotal.com/en/file/9e6ab2bb1335372cab06ef311cbaa18fe97c9... says "W32.eHeur.Dropper" detected by Bkav

https://www.metadefender.com/#!/results/file/c869301df9424b02aa49ce15d7bce692/regular/analysis says "Trojan.Dropper.Heur.gen" is detected by Baidu.

Is it correct or false positive?

ActivePerl 5.22.2 does not register dlls on Win7

On Win7 I installed AP 5.24 then found I had to use 5.22. So I uninstalled 5.24 (unused) and installed ActivePerl-5.22.2.2202-MSWin32-x86-64int-300560.exe. When I ran my perl script from the command line I received an error that perl524.dll was missing. I don't know what is still looking for perl524. This is when I searched the registry and found no dlls were registered. I did find some 'perl' entries that did point to the AP folder.

I also found that I have perl5 in Git and Anaconda on this PC.

Is AP not compatible with these?

Error installing ActivePerl 5.24 on CentOS6

All;
I was wondering if there is a way to install the new ActivePerl 5.24 on a CentOS6 server. I'm getting an error:

"perl/bin/perl: /lib64/libc.so.6: version `GLIBC_2.14' not found (required by perl/bin/perl)".

Does this mean that unless I am running CentOS7, I can no longer use new versions of ActivePerl as they become available? I have dozens of mission critical customer servers running CentOS6 so its not possible for me to simply switch operating systems.

Thanks;
Frank

CalendarMonthSimple

I'm trying to get Perl running on my new computer, but the PPM no longer provide CalendarMonthSimple. Does anyone know where there is a repository I can add in PPM to get it?

which download do I need: activeperl 5.24.0 for windows (x86)|activeperl 5.24.0 for windows (64-bit, x64)

at http://www.activestate.com/activeperl/downloads I get two choices:
download activeperl 5.24.0 for windows (x86)
download activeperl 5.24.0 for windows (64-bit, x64)

I want to continue with the same 32-64-bitness as the current AS-version I'm running.

NOTE: I'll be running PDK 9.5. Does that impact which 32-64-bitness???

Here is version info from my currently running perl version:

* perl -V:ivsize says
ivsize='8';

* perl -V:archname says
archname='MSWin32-x86-multi-thread-64int';

* perl -v says