Installation Support for ActivePerl

Installation Problems, Installer content, and FAQs for ActivePerl

Unattended installation of ActiveState ActivePearl 5.24.1.2402

I need to be able to deploy ActivePearl to multiple Windows 10 machines (via SCCM),
I can extract it to get an msi using;
"ActivePerl-5.24.1.2402-MSWin32-x64-401627.exe" /extract
But when calling this .msi I get the error:
"This Package can only be run from a bootstrapper."

Any information about unattended installation for ActivePearl?

Thanks in advance.

Perl command line interpreter has stopped working v 5.24.1 Problem Event BEX64

We recently installed perl 5.24.1 on our new windows server 2012. The very first perl script I ran I got a windows pop up that said 'Perl Command Line Interpreter has stopped working.'
The details were:
Problem Event Name: BEX64
Application Name: perl.exe
Application Version: 5.24.1.2402
Application Timestamp: 586df0fc
Fault Module Name: StackHash_c6d7
Fault Module Version: 0.0.0.0
Fault Module Timestamp: 00000000
Exception Offset: PCH_5D_FROM_ntdll+0x0000000000090C6A
Exception Code: c0000005
Exception Data: 0000000000000008
OS Version: 6.3.9600.2.0.0.272.7

re-install activeperl - any suggestions?

Hello friends,
Does anybody have any suggestions, about reinstalling ActivePerl over the installed one? (its my first time)
I didn't wanted to, but it happens that I already had ActivePerl installed at another drive and it is now messing with this one.

Thank You!!!

I didn't find the right solution from the Internet.

Need ancient ActivePerl 5.8 installer

Greetings All,

I teach biochemistry at a small liberal arts college in Kentucky, Berea College. We recently had a computer crash that wiped out my programs on a very old computer running Windows XP. To complete some proteomics experiments with my students, I really need to install a legacy version of ActivePerl, build 811 of ActivePerl 5.8. Is there any chance that someone out there still has this on an old computer that they can share? The new software is too expensive for us to upgrade, sadly.

Thanks in advance!

Matt Saderholm

Support for armv71/Raspbian?

All;
I was wondering if there is a supported version of Active Perl for the armv71/Raspbian architecture and OS? Are there any plans in the future?
Thanks;
FSD

Antivirus reported that perl contains trojan.

Hi,
I just downloaded ActivePerl community edition "ActivePerl-5.24.0.2400-MSWin32-x64-300558.exe". After running the installer, I was surprised that my Kaspersky internet security 2017 fired a warning, saying that the installer contains a trojan "PDM:Trojan.Win32.Generic". Thus my installation was not completed.
I hope that this issue should be fixed ASAP.

Mahdi.

Error installing ActivePerl 5.24

Kaspersky Endpoint Security 10 says: "Trojan.Win32.Generic" in activeperl-5.24.0.2400-mswin32-x... process.

CPAN not working - Need help

Hi,

After installing ActivePerl 5.22 x64 I´ve tried to use CPAN but all I got were error messages.
Can someone help me?

TIA
Marcus

C:\>cpan
Loading internal null logger. Install Log::Log4perl for logging messages
Redundant argument in sprintf at C:/Perl64/site/lib/CPAN.pm line 314.

cpan shell -- CPAN exploration and modules installation (v2.10)
Enter 'h' for help.

cpan[1]> upgrade
Subroutine CLONE redefined at C:\Perl64\site\lib/Storable.pm line 64.
Subroutine CAN_FLOCK redefined at C:\Perl64\site\lib/Storable.pm line 80.

ActivePerl error in SecureCRT

Has anyone found a fix for the error:

The 'PerlScript' script engine crashed during initialization.

If you are using ActivePerl, ActiveState has acknowledged this is a known problem in versions newer than 5.16. Please contact ActiveState for information regarding a fix for the problem.

This is when trying to call a perl script in VanDyke Software's SecureCRT. I have tried a few different versions of SecureCRT and none of them are working.

Currently the Versions I am trying to use are:
SecureCRT 8.0.3 (x64 build 1183)

ActivePerl License Clarification

Hi,

Our Engineering team want to use a perl script on our pre-production environment (Windows Server) that searches and replaces some values. This perl script is not included in the final product or distributed with any software or accessed by any 3rd party. Are we able to use the community edition, or does this require the purchase of a Business Edition license?

Regards,
Pantelis